hdu4004:二分:judge方法

The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they 
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).
InputThe input contains several cases. The first line of each case contains three positive integer L, n, and m. 
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.OutputFor each case, output a integer standing for the frog's ability at least they should have.Sample Input
6 1 2
2
25 3 3
11 
2
18
Sample Output
4

11

重点:judge函数,模拟青蛙跳,看过河需要跳几个石头

#include <bits/stdc++.h>
using namespace std;


int const nMax = 500005;
int stone[nMax];
int L, n, m;


bool success(int jump)
{
	if(jump * m < L)
	    return false;
	int i, j, cnt;
	i = cnt = 0;
        for(j = 1; j <= n+1; j++)
        if(stone[j] - stone[i] > jump)
	    if(j == i + 1) return false;
	    else
            {
                i = --j; //贪心,让每一次跳得尽可能远,由于为下一次循环做准备时要执行循环条件的第三部分j++,所以此处先--j。
                cnt++;
            }


	if((++cnt) > m)  //跳过河的最后一步没有记录,所以cnt要自增1。
		return false;
	return true;
}


bool cmp(int a, int b)
{
	return a < b;
}

int main()
{
        int l, r, mid;
	while(scanf("%d%d%d", &L, &n, &m) != EOF)
	{
	    stone[0] = 0;
	    for(int i = 1; i <= n; i++)
            scanf("%d", &stone[i]);
	    stone[n+1] = L;
            sort(stone+1, stone+n+1, cmp);
            l = 0; r = L;
	    while(l <= r)
	    {
	        mid = (l + r) / 2;
	        if(success(mid))
		    r = mid - 1;
	        else l = mid + 1;
	    }
	    printf("%d\n", l);
        }
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41097330/article/details/80951749