The Frog's Games HDU - 4004 二分

The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they 
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).
InputThe input contains several cases. The first line of each case contains three positive integer L, n, and m. 
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.OutputFor each case, output a integer standing for the frog's ability at least they should have.Sample Input
6 1 2
2
25 3 3
11 
2
18
Sample Output
4

11

      可以二分青蛙每次的最小跳跃距离。关键在于如何判断这个距离符合题目条件。当青蛙跳跃距离固定时,一次跳尽量多的石头,记录跳的次数,跳跃次数小于等于m则符合条件。

#include <iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=500005;
int a[maxn];
int len,m,n;
int mmax;
int judge(int d)
{
    int last=0;
    int cnt=0;
    for(int i=0;i<=n;)
    {
        if(a[i]<=last+d)i++;
        else
        {
            if(last==a[i-1])return 0;                       //如果上次跳到的位置上一块判断的石头相等,说明跳不过去了
            else
            {
                last=a[i-1];                     //可以跳到上一块,即最远满足条件的石头了
                cnt++;
            }
        }
    }
    cnt++;
    if(cnt<=m)return 1;
    else return 0;
}
int erfen()
{
    int l,r,m;
    l=1,r=len;
    int ans=0;
    while(l<=r)
    {
        m=(l+r)/2;

        if(judge(m))
        {
           r=m-1;
           ans=m;

        }
        else l=m+1;
    }
    return ans;
}
int main()
{
   // int len,m,n;
    while(cin>>len>>n>>m)
    {
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        sort(a,a+n);
       a[n]=len;

        cout<<erfen()<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/mayuqing98/article/details/79808945