2018.07.04 POJ 1113 Wall

Wall
Time Limit: 1000MS Memory Limit: 10000K
Description
Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King’s castle. The King was so greedy, that he would not listen to his Architect’s proposals to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build the wall.
这里写图片描述
Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King’s requirements.
The task is somewhat simplified by the fact, that the King’s castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle’s vertices in feet.
Input
The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King’s castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to the castle.
Next N lines describe coordinates of castle’s vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices.
Output
Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King’s requirements. You must present the integer number of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.
Sample Input
9 100
200 400
300 400
300 300
400 300
400 400
500 400
500 200
350 200
200 200
Sample Output
1628
Hint
结果四舍五入就可以了
Source
Northeastern Europe 2001


哇!!又一道简单的计算几何!这道题如果把图读懂就是一道凸包的裸板,按照它题上的说法,我们只需要求出该图形的凸包,然后将凸包的每一条边按与其垂直的方向平移 d 个单位,然后将各线段用圆弧连接构成一个新的图形,最后求出这个图形的周长即可。通过画图,我们可以发现一个显然的结论:所有圆弧的圆心角之和为 360 度,这样的话我们实际上只用求一个圆的周长加上一个凸包的周长即可。

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define N 1005
using namespace std;
double r,ans=0;
int tot=0,n,q[N],len;
struct pot{double x,y;}p[N];
inline bool cmp(pot a,pot b){return a.x==b.x?a.y<b.y:a.x<b.x;}
inline pot operator-(pot a,pot b){return pot{a.x-b.x,a.y-b.y};}
inline double cross(pot a,pot b){return a.x*b.y-a.y*b.x;}
inline double dis(pot a,pot b){return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));}
inline void graham(){
    sort(p+1,p+n+1,cmp);
    q[++tot]=1;
    for(int i=2;i<=n;++i){
        while(tot>1&&cross(p[q[tot]]-p[q[tot-1]],p[i]-p[q[tot-1]])<=0)--tot;
        q[++tot]=i;
    }
    len=tot;
    for(int i=n-1;i>=1;--i){
        while(tot>len&&cross(p[q[tot]]-p[q[tot-1]],p[i]-p[q[tot-1]])<=0)--tot;
        q[++tot]=i;
    }
    for(int i=1;i<tot;++i)ans+=dis(p[q[i]],p[q[i+1]]);
    ans+=2.0*r*3.14159265;
}
int main(){
    scanf("%d%lf",&n,&r);
    for(int i=1;i<=n;++i)scanf("%lf%lf",&p[i].x,&p[i].y);
    graham();
    printf("%lld",(long long)(ans+0.5));
    return 0;
}

猜你喜欢

转载自blog.csdn.net/dreaming__ldx/article/details/80914638