[POJ1113] Wall 凸包模板题

Problem Description
Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King's castle. The King was so greedy, that he would not listen to his Architect's proposals to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build the wall.
Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King's requirements.



The task is somewhat simplified by the fact, that the King's castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle's vertices in feet.
 

Input
The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King's castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to the castle.

Next N lines describe coordinates of castle's vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices.
 

Output
Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King's requirements. You must present the integer number of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 

Sample Input
 
  
19 100200 400300 400300 300400 300400 400500 400500 200350 200200 200
 
Sample Output
 
  
1628
 

Source

大概题意:

给你一些点,让你求这些点的凸包四边形扩大L个单位的最小周长。

题解:

首先我们需要知道一个很明显的结论:所求答案即为凸包的周长+半径为L的一个圆,分开处理即可。另外这题还要注意输出格式,多组数据每个答案之间还有额外的一个空行!我整理的凸包的解法和模板在这里

AC代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
const int Maxn=100005;
const double pi=atan(1.0)*4; 
struct node{
	int x,y;
}a[Maxn],ans[Maxn];
int n,k,lim,l;
int operator *(const node &a,const node &b){
	return a.x*b.y-a.y*b.x;
}
node operator -(const node &a,const node &b){
	node c;
	c.x=a.x-b.x;c.y=a.y-b.y;
	return c;
}
inline double dis(node a,node b){
	return sqrt(double((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y)));
} 
bool cmp(node x,node y){
	if(x.y!=y.y)return x.y<y.y;
	return x.x<y.x;
}
bool check(node o,node x,node y){
	return (x-o)*(y-o)>0?0:1;
}
void work(){
	k=0;
	double sum=0.0;
	scanf("%d%d",&n,&l);
	for(int i=1;i<=n;i++){
		scanf("%d%d",&a[i].x,&a[i].y);
	}
	sort(a+1,a+1+n,cmp);
	for(int i=1;i<=n;i++){
		while(k>=2&&check(ans[k-1],ans[k],a[i]))k--;
		ans[++k]=a[i];
	}
	lim=k;
	for(int i=n;i>=1;i--){
		while(k>=lim+1&&check(ans[k-1],ans[k],a[i]))k--;
		ans[++k]=a[i];
	}
	if(n>1)k--;
	for(int i=1;i<k;i++){
		sum+=dis(ans[i],ans[i+1]);
	}
	sum+=dis(ans[k],ans[1]);
	sum+=2*pi*l;
	printf("%.0lf\n",sum);
}
int main(){
	int t;
	scanf("%d",&t); 
	while(t--){
		work();
		if(t!=0)printf("\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/lvyanchang/article/details/80376068