POJ-1113 wall(凸包)

题目衔接:http://poj.org/problem?id=1113

Wall

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 42309   Accepted: 14432

Description

Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King's castle. The King was so greedy, that he would not listen to his Architect's proposals to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build the wall. 


Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King's requirements. 

The task is somewhat simplified by the fact, that the King's castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle's vertices in feet.

Input

The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King's castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to the castle. 

Next N lines describe coordinates of castle's vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices.

Output

Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King's requirements. You must present the integer number of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.

Sample Input

9 100
200 400
300 400
300 300
400 300
400 400
500 400
500 200
350 200
200 200

Sample Output

1628

Hint

结果四舍五入就可以了

 题目大意:给你一个城堡让你用最小的花费将其包起来,且墙离城堡最短距离为l

思路:凸包。。先计算出凸包距离,最后加上四个半圆就好了(半径为l)即一个整圆。

最后注意用c++交


/*
题目大意:给你一个城堡让你用最小的花费将其包起来,且墙离城堡最短距离为l
思路:凸包,先计算出直线上距离,最后加上四个半圆就好了
*/
#include<map>
#include<set>
#include<stack>
#include<queue>
#include<cmath>
#include<string>
#include<cstdio>
#include <vector>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
#define ll unsigned long long
#define inf 0x3f3f3f
#define esp 1e-8
#define bug {printf("mmp\n");}
#define mm(a,b) memset(a,b,sizeof(a))
#define T() int test,q=1;scanf("%d",&test); while(test--)
#define Test() {freopen("F:\\test.in","r",stdin);freopen("F:\\test1.out","w",stdout);}
const int maxn=2e4+10;
const double pi=acos(-1.0);
const int N=110;
const ll mod=1e9+7;
struct point
{
    int x,y;
} p[maxn];
int Stack[maxn],top;
///距离
double dis(point a,point b)
{
    return sqrt((double)(a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
///叉积
int mulit(point a,point b,point c)
{
    return (b.x-a.x)*(c.y-a.y)-(c.x-a.x)*(b.y-a.y);
}
///极角排序:按照该点与x轴的夹角进行逆时针比较
bool cmp(point a,point b)
{
    int temp=mulit(p[0],a,b);
    if(temp>0)
        return true;
    if(temp==0&&dis(p[0],a)<dis(p[0],b))
        return true;
    return false;
}
///凸包
void tb(int n)
{
    point p0;
    int k;
    p0=p[0];
    for(int i=1; i<n; i++)
    {
        if(p0.y>p[i].y||(p0.y==p[i].y&&p0.x>p[i].x))
        {
            p0=p[i];
            k=i;
        }
    }
    p[k]=p[0];
    p[0]=p0;
    sort(p+1,p+n,cmp);
    if(n==1)
    {
        top=0;
        Stack[0]=0;
        return ;
    }
    if(n==2)
    {
        top=1;
        Stack[0]=0;
        Stack[1]=1;
        return ;
    }
    if(n>2)
    {
        for(int i=0; i<=1; i++)
            Stack[i]=i;
        top=1;
        for(int i=2; i<n; i++)
        {
            while(top>0&&mulit(p[Stack[top-1]],p[Stack[top]],p[i])<=0)
                top--;
            top++;
            Stack[top]=i;
        }
    }
}


int main()
{
    int n,r;
    while(scanf("%d%d",&n,&r)!=EOF)
    {
        for(int i=0; i<n; i++)
            cin>>p[i].x>>p[i].y;
        tb(n);
        double ans=0;
        for(int i=0; i<top; i++)
            ans+=dis(p[Stack[i]],p[Stack[i+1]]);
        ans+=dis(p[Stack[0]],p[Stack[top]]);
        ans+=pi*(2*r);
        printf("%.0f\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lee371042/article/details/89467855