POJ - 1113 Wall ————计算几何

nce upon a time there was a greedy King who ordered his chief Architect to build a wall around the King’s castle. The King was so greedy, that he would not listen to his Architect’s proposals to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build the wall.
这里写图片描述

Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King’s requirements.

The task is somewhat simplified by the fact, that the King’s castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle’s vertices in feet.
Input
The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King’s castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to the castle.

Next N lines describe coordinates of castle’s vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices.
Output
Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King’s requirements. You must present the integer number of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.
Sample Input
9 100
200 400
300 400
300 300
400 300
400 400
500 400
500 200
350 200
200 200
Sample Output
1628
Hint
结果四舍五入就可以了


还是白书上的模板比较好用呢

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<vector>
#include<cmath>
using namespace std;
const double PI=acos(-1.0);
const double EPS=1e-10;
double add(double a,double b)
{
    if(abs(a+b)<EPS*(abs(a)+abs(b)))
        return 0;
    return a+b;
}
struct Point
{
    double x,y;
    Point () {}
    Point(double x,double y) : x(x),y(y){
    }
    Point operator + (Point p) {
        return Point(add(x,p.x),add(y,p.y));
    }
        Point operator - (Point p) {
        return Point(add(x,-p.x),add(y,-p.y));
    }
        Point operator * (double d) {
        return Point(x*d,y*d);
    }
    double dot(Point p)
    {
        return add(x*p.x,y*p.y);
    }
    double det(Point p){
        return add(x*p.y,-y*p.x);
    }
};

bool cmp_x(const Point& p,const Point& q)
{
    if(p.x!=q.x)
    return p.x<q.x;
    return p.y<q.y;
}
vector<Point> tu(Point* ps,int n)
{
    sort(ps,ps+n,cmp_x);
    int k=0;
    vector <Point>qs(n*2);
    for(int i=0;i<n;i++)
    {
        while(k>1&&(qs[k-1]-qs[k-2]).det(ps[i]-qs[k-1])<0)
        k--;
        qs[k++]=ps[i];
    }
    for(int i=n-2,t=k;i>=0;i--)
    {
        while(k>t&&(qs[k-1]-qs[k-2]).det(ps[i]-qs[k-1])<=0)
        k--;
        qs[k++]=ps[i];

    }
    qs.resize(k-1);
        return qs;
}
double dis(Point p1,Point p2)
{
    return sqrt(fabs((p1.x-p2.x)*(p1.x-p2.x)-(p1.y-p2.y)*(p1.y-p2.y)));
}
Point ps[10006];
int main()
{
    int n,m;
    scanf("%d%d",&n,&m);
    for(int i=0;i<n;i++)
        scanf("%lf %lf",&ps[i].x,&ps[i].y);
    vector <Point> qs=tu(ps,n);
    double ans=0;
    for (int i=0;i<qs.size(); i++)
        ans+=sqrt(fabs(qs[i+1].x-qs[i].x)*fabs(qs[i+1].x-qs[i].x)+fabs(qs[i+1].y-qs[i].y)*fabs(qs[i+1].y-qs[i].y));

//      ans+=dis(qs[i],qs[i+1]);//为什么?自己写的函数不行?精度不够? 
    ans+=2*PI*m;
    printf("%.0lf\n",ans);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Hpuer_Random/article/details/81350528