2018.07.04 POJ 1696 Space Ant

Space Ant
Time Limit: 1000MS Memory Limit: 10000K
Description
The most exciting space discovery occurred at the end of the 20th century. In 1999, scientists traced down an ant-like creature in the planet Y1999 and called it M11. It has only one eye on the left side of its head and just three feet all on the right side of its body and suffers from three walking limitations:
It can not turn right due to its special body structure.
It leaves a red path while walking.
It hates to pass over a previously red colored path, and never does that.
The pictures transmitted by the Discovery space ship depicts that plants in the Y1999 grow in special points on the planet. Analysis of several thousands of the pictures have resulted in discovering a magic coordinate system governing the grow points of the plants. In this coordinate system with x and y axes, no two plants share the same x or y.
An M11 needs to eat exactly one plant in each day to stay alive. When it eats one plant, it remains there for the rest of the day with no move. Next day, it looks for another plant to go there and eat it. If it can not reach any other plant it dies by the end of the day. Notice that it can reach a plant in any distance.
The problem is to find a path for an M11 to let it live longest.
Input is a set of (x, y) coordinates of plants. Suppose A with the coordinates (xA, yA) is the plant with the least y-coordinate. M11 starts from point (0,yA) heading towards plant A. Notice that the solution path should not cross itself and all of the turns should be counter-clockwise. Also note that the solution may visit more than two plants located on a same straight line.
这里写图片描述
Input
The first line of the input is M, the number of test cases to be solved (1 <= M <= 10). For each test case, the first line is N, the number of plants in that test case (1 <= N <= 50), followed by N lines for each plant data. Each plant data consists of three integers: the first number is the unique plant index (1..N), followed by two positive integers x and y representing the coordinates of the plant. Plants are sorted by the increasing order on their indices in the input file. Suppose that the values of coordinates are at most 100.
Output
Output should have one separate line for the solution of each test case. A solution is the number of plants on the solution path, followed by the indices of visiting plants in the path in the order of their visits.
Sample Input
2
10
1 4 5
2 9 8
3 5 9
4 1 7
5 3 2
6 6 3
7 10 10
8 8 1
9 2 4
10 7 6
14
1 6 11
2 11 9
3 8 7
4 12 8
5 9 20
6 3 2
7 1 6
8 2 13
9 15 1
10 14 17
11 13 19
12 5 18
13 7 3
14 10 16
Sample Output
10 8 7 3 4 9 5 6 2 1 10
14 9 10 11 5 12 8 7 6 13 4 14 1 3 2
Source
Tehran 1999

新姿势!!这道题第一眼有点蒙,然后自己 y y 了一下,难道不是每次选一个与当前点相比极角最小的点,跑过去然后重新极角排序吗?这样的话不是每个点都能被选中吗?于是写了一发,过了。上 C S D N 搜了一波发现这个东西叫做什么凸包卷包裹。听起来真是新鲜,貌似跟我的想法差不多。不过有一些细节要注意:首先这道题只按极角排序貌似是过不了样例的(大佬请忽略),需要用叉积来代替一下极角;然后就是第一次需要对所有点按照y坐标排序来找出发点,然后就没了。

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define N 55
using namespace std;
int t,n,siz;
bool vis[N];
struct pot{int x,y,id;}p[N];
inline bool cmp1(pot a,pot b){return a.y==b.y?a.x<b.x:a.y<b.y;}
inline int cross(pot a,pot b){return a.x*b.y-a.y*b.x;}
inline int dis(pot a,pot b){return (a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y);}
inline pot operator-(pot a,pot b){return pot{a.x-b.x,a.y-b.y};}
inline bool cmp2(pot a,pot b){
    int tmp=cross(a-p[0],b-p[0]);
    if(tmp==0)return dis(a,p[0])<dis(b,p[0]);
    return tmp>0;
}
int main(){
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        siz=n;
        memset(vis,0,sizeof(vis));
        for(int i=1;i<=n;++i)scanf("%d%d%d",&p[i].id,&p[i].x,&p[i].y);
        sort(p+1,p+n+1,cmp1);
        printf("%d",n);
        for(int i=1;i<=n;++i){
            printf(" %d",p[1].id);
            for(int i=1;i<=siz;++i)p[i-1]=p[i];
            --siz;
            sort(p+1,p+siz+1,cmp2);
        }
        puts("");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/dreaming__ldx/article/details/80915447