2018.07.04 POJ 2398 Toy Storage

Toy Storage
Time Limit: 1000MS Memory Limit: 65536K
Description
Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore.
Reza’s parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top:
这里写图片描述
We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.
Input
The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard.
A line consisting of a single 0 terminates the input.
Output
For each box, first provide a header stating “Box” on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.
Sample Input
4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0
Sample Output
Box
2: 5
Box
1: 4
2: 1
Source
Tehran 2003 Preliminary

这道题就是POJ2318的变体,也是一道简单计算几何,代码基本上也差不多,但本蒟蒻重敲的时候调一个小细节调了很久,其实这个问题还是 s o e a s y 的。注意到这道题的纸板没有顺序(本蒟蒻被坑的第一个点),然后请各位每次输入点时不要用 w h i l e m (本蒟蒻被坑的第二个点)。其他就没啥了,就一个二分答案+叉积判断就没了。
代码如下:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
struct pot{int x,y;};
struct line{pot a,b;}l[1005];
int n,m,x1,x2,y1,y2,cnt[1005],tot[1005];
inline pot operator-(pot a,pot b){return pot{a.x-b.x,a.y-b.y};}
inline int cross(pot a,pot b){return a.x*b.y-a.y*b.x;}
inline bool check(int k,pot p){return cross(l[k].b-p,l[k].a-p)<0;}
inline bool cmp(line a,line b){return a.a.x<b.a.x;}
inline int search(pot p){
    int l=1,r=n;
    while(l<=r){
        int mid=l+r>>1;
        if(check(mid,p))l=mid+1;
        else r=mid-1;
    }
    return r;
}
int main(){
    while(scanf("%d",&n)&&n){
        memset(cnt,0,sizeof(cnt));
        memset(tot,0,sizeof(tot));
        scanf("%d%d%d%d%d",&m,&x1,&y1,&x2,&y2);
        for(int i=1;i<=n;++i){
            scanf("%d%d",&l[i].a.x,&l[i].b.x);
            l[i].a.y=y1,l[i].b.y=y2;
        }
        sort(l+1,l+n+1,cmp);
        for(int i=1;i<=m;++i){
            pot s;
            scanf("%d%d",&s.x,&s.y);
            ++cnt[search(s)];
        }
        puts("Box");
        for(int i=0;i<=n;++i)++tot[cnt[i]];
        for(int i=1;i<=m;++i)if(tot[i])printf("%d: %d\n",i,tot[i]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/dreaming__ldx/article/details/80911143
今日推荐