HDU - 2266 D - How Many Equations Can You Find 【DFS】

How Many Equations Can You Find

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 641    Accepted Submission(s): 421

Problem Description

Now give you an string which only contains 0, 1 ,2 ,3 ,4 ,5 ,6 ,7 ,8 ,9.You are asked to add the sign ‘+’ or ’-’ between the characters. Just like give you a string “12345”, you can work out a string “123+4-5”. Now give you an integer N, please tell me how many ways can you find to make the result of the string equal to N .You can only choose at most one sign between two adjacent characters.

Input

Each case contains a string s and a number N . You may be sure the length of the string will not exceed 12 and the absolute value of N will not exceed 999999999999.

Output

The output contains one line for each data set : the number of ways you can find to make the equation.

Sample Input

123456789 3 21 1

Sample Output

18 1

题目大意:给定一串数字,你在其中添加“+”或“-”得到给定的数字

code:

#include<bits/stdc++.h>
#define ll long long
using namespace std;
char a[15];
ll ans,l,n;
void dfs(ll pos,ll sum){
	if(pos==l && sum==n){//结束条件
		ans++;return ; 
	} 
	ll temp=0;
	for(ll i=pos;i<l;i++){
		temp=10*temp+a[i]-'0';//pos之后(插入符号之后)的数 
		dfs(i+1,sum+temp);//+号
		if(pos!=0)//开头不能有-号
        dfs(i+1,sum-temp);//-号
	}
} 
int main(){
	while(cin>>a>>n){
		l=strlen(a);
		ans=0;
		dfs(0,0);
		cout<<ans<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41333844/article/details/81509111