HDU 2266-------How Many Equations Can You Find~~

Now give you an string which only contains 0, 1 ,2 ,3 ,4 ,5 ,6 ,7 ,8 ,9.You are asked to add the sign ‘+’ or ’-’ between the characters. Just like give you a string “12345”, you can work out a string “123+4-5”. Now give you an integer N, please tell me how many ways can you find to make the result of the string equal to N .You can only choose at most one sign between two adjacent characters.


Input

Each case contains a string s and a number N . You may be sure the length of the string will not exceed 12 and the absolute value of N will not exceed 999999999999.


Output

The output contains one line for each data set : the number of ways you can find to make the equation.


Sample Input

123456789 3
21 1

Sample Output

18
1

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
typedef long long ll;
char str[15];
ll n,cnt;
int len;
void dfs(int k,int sum)
{
    if(k==len)  //判断循环结束时否得到需要的值
    {
        if(sum==n)
            cnt++;
        return;
    }
    ll temp=0;
    for(int i=k;i<len;i++)   //要想得到最后的值 可能需要加的递归也需要减的递归
    {
        temp=temp*10+(str[i]-'0'); //用来计算下一个数   并且第一个数不能带-号
        dfs(i+1,sum+temp);        //加法
        if(k)  //k大于0的时候才可以有减
            dfs(i+1,sum-temp);  //减法
    }
}
int main()
{
    while(~scanf("%s%lld",str,&n))
    {
        len=strlen(str);
        cnt=0;
        dfs(0,0);
        printf("%lld\n",cnt);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/gao506440410/article/details/81333536
今日推荐