poj3186(dp)

题目链接:http://poj.org/problem?id=3186

Treats for the Cows
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7389   Accepted: 3915

Description

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.  

The treats are interesting for many reasons:
  • The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
  • Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
  • The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
  • Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?  

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.

Input

Line 1: A single integer, N  

Lines 2..N+1: Line i+1 contains the value of treat v(i)

Output

Line 1: The maximum revenue FJ can achieve by selling the treats

Sample Input

5
1
3
1
5
2

Sample Output

43

感觉又做到了一道dp的好题,拿出来分享一下。这道题关键还是构造状态转移方程(看了别人的博客才学会)。

dp[i][j]=max(dp[i-1][j]+(i+j)*(a[i]),dp[i][j-1]+(i+j)*(a[n-j+1]))

其中i表示第i次取左边的数,j表示第j次取右边的数。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
int a[2010];
ll maxn; 
ll dp[2010][2010];
int main()
{
    int n;
	scanf("%d",&n);
    for(int i=1;i<=n;i++)
    scanf("%d",&a[i]);
    dp[0][0]=0;
	maxn=0;
	for(int i=0;i<=n;i++)
	{
		for(int j=0;j<=n;j++)
		{
			if(i==0&&j==0)
			dp[i][j]=0;
			if(i==0&&j!=0)
			dp[i][j]=dp[i][j-1]+(i+j)*(a[n-j+1]);
			if(i!=0&&j==0)
			dp[i][j]=dp[i-1][j]+(i+j)*(a[i]);
			if(i!=0&&j!=0)
			dp[i][j]=max(dp[i-1][j]+(i+j)*(a[i]),dp[i][j-1]+(i+j)*(a[n-j+1]));
		}
	}
	for(int i=0;i<=n;i++)
	{
		for(int j=0;j<=n;j++)
		{
			if(i+j==n)
			maxn=max(dp[i][j],maxn); 
		}
	}
	printf("%lld\n",maxn);
	return 0;	
} 

猜你喜欢

转载自blog.csdn.net/star_moon0309/article/details/80457873