POJ3186 Treats for the Cows #区间DP#

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/qq_35850147/article/details/102478012

Treats for the Cows

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9566   Accepted: 4975

Description

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.

The treats are interesting for many reasons:

  • The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
  • Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
  • The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
  • Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.

Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.

Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains the value of treat v(i)

Output

Line 1: The maximum revenue FJ can achieve by selling the treats

Sample Input

5
1
3
1
5
2

Sample Output

43

Hint

Explanation of the sample:

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2).

FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.

Source

USACO 2006 February Gold & Silver

Solution

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long ll;

const int maxn = 2e3 + 10;
int n, v[maxn], dp[maxn][maxn];

inline const int read()
{
    int x = 0, f = 1; char ch = getchar();
    while (ch < '0' || ch > '9') { if (ch == '-') f = -1; ch = getchar(); }
    while (ch >= '0' && ch <= '9') { x = (x << 3) + (x << 1) + ch - '0'; ch = getchar(); }
    return x * f;
}

int main()
{
    while (~scanf("%d", &n))
    {
        memset(dp, 0, sizeof(dp));
        for (int i = 1; i <= n; i++) v[i] = read();
        for (int i = n - 1; i >= 1; i--)
            for (int j = i; j <= n; j++)
                dp[i][j] = max(dp[i + 1][j] + v[i] * (n + i - j), dp[i][j - 1] + v[j] * (n + i - j));
        printf("%d\n", dp[1][n]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_35850147/article/details/102478012