Treats for the Cows POJ - 3186(区间DP)

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.

The treats are interesting for many reasons:
The treats are numbered 1…N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.
Input
Line 1: A single integer, N

Lines 2…N+1: Line i+1 contains the value of treat v(i)
Output
Line 1: The maximum revenue FJ can achieve by selling the treats
Sample Input
5
1
3
1
5
2
Sample Output
43
Hint
Explanation of the sample:

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2).

FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.

题意:
n个数字。每次从首尾取一个数字,第i次取则获得价值为a[x] * i。求取完所有数字的最大价值
思路:
区间DP。
令dp[i][j]为取完区间i~j的最大价值。
知道了区间后很容易知道当前是第几次取数,也就是n减去剩余的数字再加1,对于子状态dp[i+1][j]与dp[i][j-1],当前为第n - j + i次取数。

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int a[2005];
int dp[2005][2005];

int main()
{
    int n;scanf("%d",&n);
    for(int i = 1;i <= n;i++)scanf("%d",&a[i]);
    for(int len = 1;len <= n;len++)
    {
        for(int i = 1;i + len - 1 <= n;i++)
        {
            int j = i + len - 1;
            int x = i + (n - j);
            dp[i][j] = max(dp[i + 1][j] + a[i] * x,dp[i][j - 1] + a[j] * x);
        }
    }
    
    printf("%d\n",dp[1][n]);
    return 0;
}
发布了676 篇原创文章 · 获赞 18 · 访问量 3万+

猜你喜欢

转载自blog.csdn.net/tomjobs/article/details/104230325