Treats for the Cows POJ - 3186 (区间dp)

Treats for the Cows

POJ - 3186

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7360   Accepted: 3897

Description

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.

The treats are interesting for many reasons:
  • The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
  • Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
  • The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
  • Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.

Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains the value of treat v(i)

Output

Line 1: The maximum revenue FJ can achieve by selling the treats

Sample Input

5
1
3
1
5
2

Sample Output

43

Hint

Explanation of the sample:

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2).

FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.

Source


题意:给一个数组v,每次可以取最前面的或者最后面的,第k次取的v[i]价值为v[i]*k,问总价值最大是多少。

区间dp。

设dp[i][j] 为 取i到j后 的最大值,可能由d[i+1][j]或者d[i][j-1]转移而来。

转移方程:dp[i][j]=max(dp[i+1][j]+p[i]*(n+i-j),dp[i][j-1]+p[j]*(n+i-j));  其中n-(j-i)是第几次取

从n开始往前逆推

code:

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int p[2010];
int dp[2010][2010];
int n;
int main(){
    while(scanf("%d",&n) != EOF){
        memset(dp,0,sizeof(dp));
        for(int i = 1; i <= n; i++){
            scanf("%d",&p[i]);
            dp[i][i] = p[i];
        }
        int ans = 0;
        for(int i = n; i >= 1; i--){
            for(int j = i; j <= n; j++){
                dp[i][j] = max(dp[i+1][j]+p[i]*(n+i-j),dp[i][j-1]+p[j]*(n+i-j));
            }
        }
        printf("%d\n",dp[1][n]);
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/codeswarrior/article/details/80391108