DP专题--------O - Treats for the Cows 区间DP

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.

The treats are interesting for many reasons:
The treats are numbered 1…N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.
Input
Line 1: A single integer, N

Lines 2…N+1: Line i+1 contains the value of treat v(i)
Output
Line 1: The maximum revenue FJ can achieve by selling the treats
Sample Input
5
1
3
1
5
2
Sample Output
43
Hint
Explanation of the sample:

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2).

FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.

刚开始感觉状态转移特别难找,但是听说是区间DP,顿时大悟,dp[i][j]代表i到j所取到的最大价值;
状态转移很好就看出来了,就是从dp[i + 1][j] 和 dp[i][j - 1];
dp[i][j] = max(dp[i + 1][j] + t * a[i],dp[i][j - 1] + t * a[j]);
t代表n + j - i;初始化dp[i][i] = n * a[i];
然后一层一层从对角线斜着推出dp[1][n],就是最终答案;

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int inf = 0x3f3f3f3f;
#define mp make_pair
#define pb push_back
#define fi first
#define se second

int dp[2005][2005];
int a[2005];

int main()
{
    int n;
    while(~scanf("%d",&n)){
        for(int i = 1;i <= n;++i){
            scanf("%d",&a[i]);
        }
        memset(dp,0,sizeof(dp));
        for(int i = 1;i <= n;++i){
            dp[i][i] = n * a[i];
        }
        for(int k = 1;k < n;++k){
            for(int i = 1;i + k <= n;++i){
                int j = i + k;
                dp[i][j] = max(dp[i + 1][j] + a[i] * (n - k),dp[i][j - 1] + a[j] * (n - k));
            }
        }
        printf("%d\n",dp[1][n]);
    }
    return 0;
}

发布了269 篇原创文章 · 获赞 33 · 访问量 8万+

猜你喜欢

转载自blog.csdn.net/qq_36386435/article/details/89186613
今日推荐