HDOJ-1213 How Many Tables

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24368    Accepted Submission(s): 12194


Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

Sample Input
  
   
   
2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output
  
   
   
2 4
 
介个题就是最基本的并查集算法,水题,算法会了就行!
代码:
#include <stdio.h>
#include <iostream>
#include <algorithm>
using namespace std;
int fa[1001];
void init()
{
	for(int i=1;i<1001;i++)
	    fa[i]=i;
}
int findroot(int x)
{
	if(x==fa[x]) return x;
	fa[x]=findroot(fa[x]);
	return fa[x];
}
void Union(int a,int b)
{
	int na=findroot(a);
	int nb=findroot(b);
	if(na!=nb) fa[nb]=na;
}
int main()
{
	int t,n,m;
	scanf("%d",&t);
	while(t--)
	{
		init(); 
		scanf("%d%d",&n,&m);
		for(int i=1;i<=m;i++)
		{
			int a,b;
			scanf("%d%d",&a,&b);
		    Union(a,b);
		}
		int cnt=0;
		for(int i=1;i<=n;i++)
		    if(fa[i]==i) cnt++;
		printf("%d\n",cnt);
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/Poseidon__ming/article/details/52087658