【 HDU - 1062 】B - Text Reverse 文本翻转(水题stringstream)

题目:

Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
Output
For each test case, you should output the text which is processed.
Sample Input
3
olleh !dlrow
m’I morf .udh
I ekil .mca
Sample Output
hello world!
I’m from hdu.
I like acm.

Hint
Remember to use getchar() to read ‘\n’ after the interger T, then you may use gets() to read a line and process it.


本来用stringstream,一直显示格式不对

代码(格式错误):

#include<iostream>
#include<algorithm>
#include<sstream> 
using namespace std;
typedef long long ll;
const int maxn=2e5+50;
string x;
int main()
{
    
    
	int t;
	string s;
	cin>>t;
	cin.get();
	while(t--)
	{
    
    
		getline(cin,s);
		stringstream ss(s); //通过字符串流
		while(ss>>x)
		{
    
    
			reverse(x.begin(),x.end()); //翻转即可
			cout<<x<<" ";
		}
		cout<<endl;
	}
    return 0;
}

不知道啥格式问题,于是老老实实模拟一遍

AC代码:

#include <iostream>
#include <algorithm>
#include <string>
using namespace std;
int main() 
{
    
    
	int n;
	string s;
	cin>>n;
    cin.get();
	while(n--)
	{
    
    
		getline(cin,s);
		string t; //将字符串中单词放在t中
		for(int i=0;i<s.length();i++)
		{
    
    
			if(s[i]==' ')   //遇到空格,将前面保存的t翻转输出
			{
    
    
				reverse(t.begin(),t.end());
				cout<<t<<" ";
				t.clear(); //清理上一个单词
			}
			else t += s[i];  //不是空格,继续拼接单词
		}
		reverse(t.begin(),t.end()); //最后还有一个单词,翻转输出
		cout<<t<<endl;
	}
   	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_45260385/article/details/108201534