(reverse) Text Reverse hdu1062

Text Reverse

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 35208    Accepted Submission(s): 13824

Problem Description

Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output

For each test case, you should output the text which is processed.

Sample Input

3

olleh !dlrow

m'I morf .udh

I ekil .mca

Sample Output

hello world!

I'm from hdu.

I like acm.

Hint

Remember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
int main()  
{  
    int n; 
    char a[1010]; 
    cin>>n;  
    getchar();               //别忘了要输入。
    while(n--)  
    {  
        gets(a);  
        int len = strlen(a);  
        int s=0,e=0;  
        for(int i=0;i<len;i++)  
        {  
            if(a[i]==' ')  
            {  
                e = i;  
                reverse(a+s,a+e);            //对于C语言的字符串表示方式使用,但是对于string并不适用。
                s=e+1;  
            }
        }  
        if(a[len-1]!=' ')     //要考虑每行的字符串的最后一个字符是否为空格。
        {  
            e = len;  
            reverse(a+s,a+e);  
        }  
        printf("%s\n",a);  
     }   
    return 0;  
} 

猜你喜欢

转载自www.cnblogs.com/Weixu-Liu/p/9272624.html