HDU-1062(Text Reverse)

Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output

For each test case, you should output the text which is processed.

Sample Input
3
olleh !dlrow
m'I morf .udh
I ekil .mca
Sample Output
hello world!
I'm from hdu.
I like acm.
//用C语言处理字符串问题,c++中取消的gets() 和strlen()两个函数 
#include<stdio.h>
#include<string.h>
char str[1010];
int main(){
	int t;
	scanf("%d",&t);
	getchar();//getchar()用于缓冲,不可小看他的作用 
	while(t--){
		gets(str);
		int len=strlen(str);
		int start=0;
		bool flag=0;
		for(int i=0;i<len;i++){
			if(str[i]==' '){
				if(flag)	
					printf(" ");
				for(int k=i-1;k>=start;k--)
					printf("%c",str[k]);
				start=i+1;
				flag=1;
			}
			if(i==len-1){
				printf(" ");
				for(int k=i;k>=start;k--)
					printf("%c",str[k]);
			}
		}
		puts("");
	}
}
/*Sample Input
3
olleh !dlrow
m'I morf .udh
I ekil .mca

Sample Output
hello world!
I'm from hdu.
I like acm.
*/
发布了73 篇原创文章 · 获赞 27 · 访问量 1231

猜你喜欢

转载自blog.csdn.net/queque_heiya/article/details/103837382