HDU 1062 Text Reverse (reverse)

题目

Problem Description

Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output

For each test case, you should output the text which is processed.

Sample Input

3
olleh !dlrow
m’I morf .udh
I ekil .mca

Sample Output

hello world!
I’m from hdu.
I like acm.

Hint

Remember to use getchar() to read ‘\n’ after the interger T, then you may use gets() to read a line and process it.

代码

#include <bits/stdc++.h>
#include <iostream>
#include <vector>
using namespace std;
int main ()
{
    
    
    int n;
    cin>>n;
    getchar();  //要记得getchar不然会被看成是下面s的输入
    while (n)
    {
    
    
        stack <char> s;  //栈
        while (1)
        {
    
    
            char c=getchar();
            if (c==' ')
            {
    
    
                while (!s.empty())
                {
    
    
                    cout<<s.top();
                    s.pop();
                }
                cout<<" ";
            }
            else if (c=='\n')
            {
    
    
                while (!s.empty())
                {
    
    
                    cout<<s.top();
                    s.pop();
                }
                cout<<endl;
            break;
            }
            else
                s.push(c);
        }
        n--;
    }
    return 0;
}

理解

本来想用ppt前面说的reverse做,但是由于翻转是一个一个单词反转的,关于如果输入很多空格该怎样控制输出我没有想出来。
看了ppt以后明白了他是利用栈,一个一个输入然后判断的。

猜你喜欢

转载自blog.csdn.net/weixin_44918971/article/details/95625792