Text Reverse

Problem Description

Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output

For each test case, you should output the text which is processed.

Sample Input

3
olleh !dlrow
m'I morf .udh
I ekil .mca

Sample Output

hello world!
I'm from hdu.
I like acm.

Hint

Remember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<stack>
using namespace std;
int main(){
    stack<char>zhan;
    int n;
    cin>>n;
    getchar();
    while(n--){
        char a[1005];
        while(!zhan.empty()){
            zhan.pop();
        }
        gets(a);
        //cout<<a<<endl;
        int i;
        char c;
        for(i=0;i<strlen(a);i++){
            c=a[i];
            if(c!=' ')
            zhan.push(c);
            if(c==' '||i == strlen(a)-1){
                while(!zhan.empty()){
                    printf("%c",zhan.top());
                    zhan.pop();
                }
                if(c==' ') 
                    printf(" ");
    
            }
        
        }printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wys5wys/article/details/88256128