杭电OJ1062---Text Reverse(c++)(C++库getline的使用)

Text Reverse

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 54493    Accepted Submission(s): 20797


 

Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
 
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
 
Output
For each test case, you should output the text which is processed.
 
Sample Input
 
3 olleh !dlrow m'I morf .udh I ekil .mca
 
Sample Output
 
hello world! I'm from hdu. I like acm.
Hint

Remember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.

题解:

#include<cstdio>
#include<iostream>
#include<cmath>
#include<string>
using namespace std;
int main()
{
    int n;
    cin >> n;
    getchar();
    while (n--)
    {
        int k = 0;
        string str;
        getline(cin,str);
        for (int i = 0; i<str.length();i++)
        {
            if (str[i] == ' ')
            {
                for (int m = i - 1; m >= k; m--)
                {
                    cout << str[m];
                }
                cout << " ";
                k = i + 1;
            }
        }
            for (int m = str.length()- 1; m >=k; m--)
                cout << str[m];
            cout << endl;
    }
    return 0;
}

 

猜你喜欢

转载自blog.csdn.net/weixin_45965358/article/details/107213618