B - B Silver Cow Party (最短路+转置)

题意:

    给N个牧场,每个牧场里有一头牛,他们都要到第X个牛的牧场里聚会,然后返回各自的牧场,给定M组数据,代表从x到y牧场所用的时间(有向),问来回时间最长的牛所花费的时间,都是走最短路径;

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively:  NM, and  X 
Lines 2.. M+1: Line  i+1 describes road  i with three space-separated integers:  AiBi, and  Ti. The described road runs from farm  Ai to farm  Bi, requiring  Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int n,m,x,minn,k,ans=0;
int dp[1005][1005];
int dis[1005],vis[1005],dis2[1005];
const int inf=99999999;

void djk(int x)
{
    for(int i=1;i<=n;i++)
        vis[i]=0;
    vis[x]=1;
    for(int i=1;i<=n;i++)//记录点i到x的距离
        dis[i]=dp[x][i];
    for(int i=1;i<=n;i++)
    {
        minn=inf;
        for(int j=1;j<=n;j++)//两个农场之间取最短的路径
        {
            if(!vis[j]&&dis[j]<minn)
            {
                minn=dis[j];
                k=j;
            }
        }
        vis[k]=1;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&dis[j]>dis[k]+dp[k][j])
                dis[j]=dis[k]+dp[k][j];
        }
    }
}
int main()
{
     while(scanf("%d %d %d",&n,&m,&x)!=EOF)
     {
        for(int i=0;i<=n;i++)//这里i的范围要取小于n,如果取小于1005z则会runtime error
           {//重置数组
               for(int j=0;j<=n;j++)
            {
                if(i==j)
                   dp[i][j]=0;
            else
                dp[i][j]=inf;
               }
        }
           for(int i=0;i<m;i++)
        {
            int u,v,w;
            scanf("%d %d %d",&u,&v,&w);
            if(dp[u][v]>w)
                dp[u][v]=w;
        }
           djk(x);
        for(int i=1;i<=n;i++)
               dis2[i]=dis[i];//记录distant函数之后的dis的数据
 
        for(int i=1;i<=n;i++)
        {
            for(int j=i+1;j<=n;j++)
            {
                    int tem;
                tem=dp[j][i];
                dp[j][i]=dp[i][j];
                dp[i][j]=tem;
            }
        }
        djk(x);
            for(int i=1;i<=n;i++)
        {
            ans=max(ans,dis2[i]+dis[i]);
        }
        printf("%d\n",ans);
    }
}

猜你喜欢

转载自www.cnblogs.com/csx-zzh/p/13401888.html