POJ-3268-Silver Cow Party(最短路)

                                                     Silver Cow Party
 

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2..M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

题意描述:

找出x到各个点的最短路和各个点到x的最短路然后输出和的最大值

程序代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
void F(int s,int e[][1010]);
#define inf 99999999
int dis[1010],book[1010],e[1010][1010],f[1010][1010],d[1010],n,m;
int main()
{
	int i,j,k,x,a,b,c,maxn,temp;
	while(scanf("%d%d%d",&n,&m,&x)!=EOF)
	{
		memset(d,0,sizeof(d));
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
				if(i==j)
				{
					e[i][j]=0;
					f[i][j]=0;
				}
					
				else
				{
					e[i][j]=inf;
					f[i][j]=inf;
				}
					
		for(i=1;i<=m;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			if(c<e[a][b])
			{
				e[a][b]=c;
				f[b][a]=c;
			}
		}
		F(x,e);
		F(x,f);
		maxn=-1;
		for(i=1;i<=n;i++)
		{
			if(d[i]>maxn)	
				maxn=d[i];
		}	
		printf("%d\n",maxn);
	}
	return 0;
}
void F(int s,int e[][1010])
{
	int i,j,k,min,u;
	for(i=1;i<=n;i++)
		dis[i]=e[s][i];
	memset(book,0,sizeof(book));
	book[s]=1;
	for(k=1;k<n;k++)
	{
		min=inf;
		for(i=1;i<=n;i++)
			if(book[i]==0&&dis[i]<min)
			{
				min=dis[i];
				u=i;
			}
		book[u]=1;
		for(i=1;i<=n;i++)
			if(book[i]==0&&dis[i]>dis[u]+e[u][i])
				dis[i]=dis[u]+e[u][i];
	}	
	for(i=1;i<=n;i++)
		d[i]+=dis[i];
}

猜你喜欢

转载自blog.csdn.net/HeZhiYing_/article/details/81431464