Silver Cow Party(最短路+矩阵转置)

Silver Cow Party
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 27135   Accepted: 12393

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti(1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively:  NM, and  X 
Lines 2.. M+1: Line  i+1 describes road  i with three space-separated integers:  AiBi, and  Ti. The described road runs from farm  Ai to farm  Bi, requiring  Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

由于道路时单向的,而Floyd算法超时。

从a到b的最短路,是将邻接矩阵转置后的从b到a的最短路!

可以做到O(n^2)的复杂度

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <string>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <sstream>
#include <map>

#define INF 1000000
#define eps 1e-5
using namespace std;



int vis[1005];
int n,m,X;

void dijstra(int *lowcost,int G[1005][1005])
{
	memset(vis,0,sizeof(vis));
	lowcost[X]=0;
	while(1)
	{
		int k=-1;
		int Min=INF;
		for(int i=1;i<=n;i++)
		{
			if(vis[i]==0 && lowcost[i]<Min)
			{
				Min=lowcost[i];
				k=i;
			}
		}
		if(k==-1) break;
		vis[k]=1;
		for(int i=1;i<=n;i++)
		{
			if(vis[i]==0 && lowcost[i]>lowcost[k]+G[k][i])
			{
				lowcost[i]=lowcost[k]+G[k][i];
			}
		}
	}
}

int G[1005][1005],G2[1005][1005];
int main()
{
	
	while(scanf("%d%d%d",&n,&m,&X)==3)
	{
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				G[i][j]=INF;
			}
			G[i][i]=0;
		}
		while(m--)
		{
			int a,b,c;
			scanf("%d%d%d",&a,&b,&c);
			G[a][b]=c;
		}
		int lowcost1[1005];
		for(int i=1;i<=n;i++)
		{
			lowcost1[i]=INF;
		}
		dijstra(lowcost1,G);
		int lowcost2[1005];
		for(int i=1;i<=n;i++)
		{
			lowcost2[i]=INF;
		}
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				G2[i][j]=G[j][i];
			}
		}
		dijstra(lowcost2,G2);
		int s[1005];
		int Max=0;
		for(int i=1;i<=n;i++)
		{
			s[i]=lowcost1[i]+lowcost2[i];
			Max=max(Max,s[i]);
		}
		printf("%d\n",Max);
	}
	return 0;
}
		


Floyd超时代码:O(n^3)的复杂度

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <string>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <sstream>
#include <map>

#define INF 1000000
#define eps 1e-5
using namespace std;

int n,m,X;
int d[1005][1005];
int s[1005];
int G[1005][1005];

void floyd()
{
	for(int i=1;i<=n;i++)
	{
		for(int j=1;j<=n;j++)
		{
			d[i][j]=G[i][j];
		}
	}
	for(int k=1;k<=n;k++)
	{
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				if(d[i][j]>d[i][k]+d[k][j])
				{
					d[i][j]=d[i][k]+d[k][j];
				}
			}
		}
	}

}

int main()
{
	while(scanf("%d%d%d",&n,&m,&X)==3)
	{
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				G[i][j]=INF;
			}
			G[i][i]=0;
		}
		while(m--)
		{
			int a,b,c;
			scanf("%d%d%d",&a,&b,&c);
			G[a][b]=c;
		}
		floyd();
		for(int i=1;i<=n;i++)
		{
			s[i]=d[i][X]+d[X][i];
		}
		int Max=0;
		for(int i=1;i<=n;i++)
		{
			if(s[i]>Max)
			{
				Max=s[i];
			}
		}
		printf("%d\n",Max);
	}

	return 0;
}

猜你喜欢

转载自blog.csdn.net/zl1085372438/article/details/80443865