POJ - 3268 ——Silver Cow Party【最短路】

Silver Cow Party
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 27055   Accepted: 12357

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively:  NM, and  X 
Lines 2.. M+1: Line  i+1 describes road  i with three space-separated integers:  AiBi, and  Ti. The described road runs from farm  Ai to farm  Bi, requiring  Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top



All Rights Reserved 2003-2013 Ying Fuchen,Xu Pengcheng,Xie Di

Any problem, Please Contact Administrator

题目大意:就是一群分别来自各个农场的牛要去一个指定的农场开会,问这群牛去农场和回农场所花费的时间的最小值在这群牛中的最大是多少?

这道题可以这样理解,首先把图正向存一遍用来求目的地到各个农场的最小距离,然后在把图反向存一遍相当于从农场回家时又要的最小距离。总之就是求一个点到多个点的最短距离。

#include<algorithm>
#include<cstdio>
#include<iostream>
#include<cstring>
#include<queue>
#define INF 0x3f3f3f3f
using namespace std;
const int MAXN=10010;
int head[MAXN],u[MAXN],v[MAXN],w[MAXN];
int vis[MAXN],dis[MAXN],time[MAXN];
int n,m,s,top;
struct node{
	int to,next,cost;
}e[100000+10];
void addEdge(int u,int v,int  cot){
	e[top].to=v;
	e[top].next=head[u];
	e[top].cost=cot;
	head[u]=top++;
}
void spfa(int s){
	memset(dis,INF,sizeof(dis));
	dis[s]=0;
	memset(vis,0,sizeof(vis));
	vis[s]=1;
	queue<int>que;
	while(!que.empty()) que.pop();
	que.push(s);
	while(!que.empty()){
		int x=que.front();
		que.pop();
		vis[x]=0;
		for(int i=head[x];i!=-1;i=e[i].next){
			int y=e[i].to,z=e[i].cost;
			if(dis[y]>dis[x]+z){
				dis[y]=dis[x]+z;
				if(!vis[y]){
					que.push(y);
					vis[y]=1;
				}
			}
		}
	}
	for(int i=1;i<=n;i++){
		time[i]=dis[i]+time[i];
	}
}
int main(){
	while(~scanf("%d%d%d",&n,&m,&s)){
		memset(head,-1,sizeof(head));
		top=0;
		memset(time,0,sizeof(time));
		for(int i=1;i<=m;i++){
			scanf("%d%d%d",&u[i],&v[i],&w[i]);//正向存图
			addEdge(u[i],v[i],w[i]); 
		}
		spfa(s);
		memset(head,-1,sizeof(head));
		top=0;
		for(int i=1;i<=m;i++){
			addEdge(v[i],u[i],w[i]);//反向存图 ,把图反向再求一次 
		}
		spfa(s);
		int maxx=0;
		for(int i=1;i<=n;i++){
			maxx=max(maxx,time[i]);
		}
		printf("%d\n",maxx);
	}
	return 0; 
}

猜你喜欢

转载自blog.csdn.net/xiang_hehe/article/details/80349548