Silver Cow Party (Dijkstra)

    One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

    Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

    Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?
Input
    Line 1: Three space-separated integers, respectively: N, M, and X
    Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.
Output
    Line 1: One integer: the maximum of time any one cow must walk.
Sample Input

    4 8 2
    1 2 4
    1 3 2
    1 4 7
    2 1 1
    2 3 5
    3 1 2
    3 4 4
    4 2 3

Sample Output

    10

Hint
    Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

题意:有n个农厂,n头牛,其中标号为x的农场要举行party,其余农场的牛要去参加,但是牛都很懒,所以不管是过去还是回来,牛都会走对于他们自己而言最短的路,要你求出所有牛中走得时间最长的一个。

分析:这道题首先计算出每头牛来回的最短距离和,然后再进行比较,输出最大值。

我的方法是用两次Dijkstra,分别算出去和回来的最小值,再求和。

#include<stdio.h>
#include<string.h>

int m,n,u,max,e[1005][1005],dis1[1005],dis2[1005],book[1005];
int inf = 99999999;
void Dijkstra()
{
	int i,j,k,min;
	for(i = 1; i <= n; i ++)
	{
		dis1[i] = e[u][i];
		dis2[i] = e[i][u];
		book[i] = 0;
	}
	for(i = 1; i < n; i ++)
	{
		min = inf;
		for(j = 1; j <= n; j ++)
			if(book[j] == 0 && dis1[j] < min)
			{
				min = dis1[j];
				k = j; 
			}
		book[k] = 1;
		for(j = 1; j <= n; j ++)
			if(book[j] == 0 && dis1[j] > dis1[k] + e[k][j])
				dis1[j] = dis1[k] + e[k][j];
	}
	memset(book,0,sizeof(book));
	for(i = 1; i < n; i ++)
	{
		min = inf;
		for(j = 1; j <= n; j ++)
			if(book[j] == 0 && dis2[j] < min)
			{
				min = dis2[j];
				k = j; 
			}
		book[k] = 1;
		for(j = 1; j <= n; j ++)
			if(book[j] == 0 && dis2[j] > dis2[k] + e[j][k])
				dis2[j] = dis2[k] + e[j][k];
	}
	for(i = 1; i <= n; i ++)
	{
		if(dis1[i] + dis2[i] > max)
			max = dis1[i] + dis2[i];
	}
	printf("%d\n",max);
}
int main()
{
	int i,j,t1,t2,t3;
	while(scanf("%d%d%d",&n,&m,&u) != EOF)
	{
		max = 0;
		for(i = 1; i <= n; i ++)
			for(j = 1; j <= n; j ++)
				if(i == j)
					e[i][j] = 0;
				else
					e[i][j] = inf;
		for(i = 1; i <= m; i ++)
		{
			scanf("%d%d%d",&t1,&t2,&t3);
			e[t1][t2] = t3;
		}
		Dijkstra();
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/queen00000/article/details/81430279