The Suspects poj 1611

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output

4
1
1
将所有 有联系的人划分到一个区域,最后形成若干个区域,再逐个检查是否所在的区域于0所在区域为一个区域,若是,则是嫌疑人。


#include <iostream>

using namespace std;

int father[30005];

void init(int n)
{
    for(int i = 0; i < n; i++){//对父节点的初始化;
        father[i] = i;
    }
}

int Search(int node)//找到最上级的父结点;
{
    int son = node,tmp;
     while(father[node] != node){
        node = father[node];
     }
     while(son != node) //路径压缩,因为只关心上级,而不关心怎么
     {                   //所构成的路径结构,优化查找复杂度;
		tmp = father[son];
		father[son] = node;
		son = tmp;
	 }
     return node;
}

int main()
{
    int n,m,stu[30005];
    while(cin>>n>>m){
        if(!m&&!n)
            break;
        init(n);
        for(int i = 0; i < m; i++){//将所有人进行划分成若干个区域
            int k;
            cin>>k;
            for(int j = 0; j < k; j++){
                cin>>stu[j];
            }
            for(int l = 0; l < k - 1; l++){
                int r1 = Search(stu[l]),r2 = Search(stu[l + 1]);
                if(r1 != r2){
                    father[r1] = r2;
                }
            }
        }
        int sum = 0;
        for(int i = 0; i < n; i++){//检查是否跟0号一个区域
            if(Search(0) == Search(i))
                sum++;
        }
        cout<<sum<<endl;
    }
    return 0;
}

Cu1
发布了30 篇原创文章 · 获赞 2 · 访问量 942

猜你喜欢

转载自blog.csdn.net/CUCUC1/article/details/105345098