POJ---1611 The Suspects

The Suspects

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1

本题题意:首先输入两个数,学生个数n(编号从0开始)和测试次数m,在每个测试中输入一个k代表有多少个学生在那个组里面,然后编号为0的学生是感染者,会感染所在组的所有人,编号为0的学生所在组的其它人,也有可能在另一个或多个组,感染其他组内的所有人,问最后有多少人被感染。

本题思路:本题无非就是要返回编号为0的学生所组成的总人数,感染的嫌疑者可以归并到编号为0的学生的集合中,最后统计该集合的数目,这里我们可以在合并集合中把感染了的学生加起来,最后得出感染学生的总人数。(用sum[]数组记录当前下标为根节点的集合内元素的数目,最后输出0为根节点所在集合的元素个数)

AC代码如下:

#include<iostream>
using namespace std;
const int maxn = 3e4 + 5;
int par[maxn];
int sum[maxn];
void init(int n)
{
	for (int i = 0; i <= n; i++)
	{
		par[i] = i;
		sum[i] = 1;//每个集合个数的初始值为1
	}
}

int find(int x)
{

	if (par[x] != x)x = find(par[x]);
	return par[x];
}

void unite(int x, int y)
{
	x = find(x);
	y = find(y);
	if (x != y)
	{
		par[x] = y;//将x的father变为y
		sum[y] += sum[x];//y的集合个数加上x集合的个数
	}
}

int main()
	{
	int n, m;
	while (cin >> n >> m&&n)
	{
		init(n);
		for (int i = 0; i < m; i++)
		{
			int k;
			cin >> k;
			int x;
			cin >> x;
				k--;
			while (k--)
			{
				int y;
				cin >> y;
				unite(x, y);
			}
		}
		cout << sum[find(0)] << endl;
		//找到根节点为0的集合的个数就是感染的人数
	}
	return 0;
}
发布了40 篇原创文章 · 获赞 10 · 访问量 2564

猜你喜欢

转载自blog.csdn.net/lsdstone/article/details/101347063