The Suspects(POJ-1611)

点我跳转 POJ - 1611

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of
students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1


题目大意

有个标号为0号的学生疑似患病,跟0号学生属于一个组里面的其他学生也会被列为疑似患病,要我们求总共有多少个人疑似患病

解题思路

把给定每个组的成员合并起来,然后遍历n个学生,看看这些学生是否跟0号学生属于同一个集合,若属于同一个集合就说明他也是疑似患病的

AC代码

#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
const int maxn = 31111;
int fa[maxn];
void init()
{
	for(int i = 0 ; i < maxn ; i++)
	{
		fa[i] = i;
	}
}
int Find(int x)
{
	return fa[x] == x?x:fa[x] = Find(fa[x]);
}
void unite(int x, int y)
{
	fa[Find(x)] = Find(y);
}
int main()
{
	int n,m;
	while(scanf("%d %d",&n,&m)!=EOF)
	{
		init();
		if(n == 0 && m == 0){	break;}
		for(int i = 0 ; i < m ; i++)
		{
			int k;
			int front;//组长
			int back;//组员
			scanf("%d",&k);
			scanf("%d",&front);
			for(int i = 1 ; i < k; i++)
			{
				scanf("%d",&back);
				unite(front,back);
			}
		}
		int p = 0;
		for( int i = 0 ; i < n ; i++)
		{
			if(Find(i) == Find(0))//跟0号同学是一个集合
			{
				p++;
			}
		}
		printf("%d\n",p);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_46425926/article/details/107572059