HDU 4496 D-CITY(并查集)

D-City

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 5315    Accepted Submission(s): 1856


Problem Description
Luxer is a really bad guy. He destroys everything he met.
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input.
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.
 

Input
First line of the input contains two integers N and M.
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.
Constraints:
0 < N <= 10000
0 < M <= 100000
0 <= u, v < N.
 

Output
Output M lines, the ith line is the answer after deleting the first i edges in the input.
 

Sample Input
 
  
5 10 0 1 1 2 1 3 1 4 0 2 2 3 0 4 0 3 3 4 2 4
 
Sample Output
 
  
1 1 1 2 2 2 2 3 4 5
Hint
The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there's only 1 connected block at first. The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together. But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block. Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.
 

Source

算法分析:

本题要求删除边,然后求每次删后图的连通分量, 然后我们可以到过想,假设删除k条边,其实不就是添加m-k边吗,所以仅需倒序插入每条边,分别保存插入边后新图所具有的连通分量数目在数组内,然后输出数组即可

代码实现:

#include<cstdio>  
using namespace std;
#define N  10005
#define M  1100005
int x[M],y[M],fa[N+100];
int sum[M];//记录i时连通分量数目
int findset(int x)
{
    return fa[x]==x?x:fa[x]=findset(fa[x]);
}
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)==2)
    {for(int i=1;i<=m;i++)
        scanf("%d%d",&x[i],&y[i]);
    for(int i=0;i<=n;i++)
        fa[i]=i;
        sum[m]=n;//一条边都没有的时候的连通分量
    for(int i=m;i>=1;i--)
    {
        int r1=findset(x[i]),r2=findset(y[i]);
        if(r1!=r2)//新的连通分量
        {
            fa[r1]=r2;
            sum[i-1]=sum[i]-1;
        }
        else
            sum[i-1]=sum[i];
    }
    for(int i=1;i<=m;i++)
        printf("%d\n",sum[i]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdz20172133/article/details/80172520