D-City

D-City

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 6079    Accepted Submission(s): 2112


Problem Description
Luxer is a really bad guy. He destroys everything he met. 
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input. 
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.
 
Input
First line of the input contains two integers N and M. 
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line. 
Constraints: 
0 < N <= 10000 
0 < M <= 100000 
0 <= u, v < N. 
 
Output
Output M lines, the ith line is the answer after deleting the first i edges in the input.
 
Sample Input
5 10 0 1 1 2 1 3 1 4 0 2 2 3 0 4 0 3 3 4 2 4
 
Sample Output
1 1 1 2 2 2 2 3 4 5
Hint
The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there's only 1 connected block at first. The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together. But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block. Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.
#include <bits/stdc++.h>

using namespace std;
const int maxn = 6e5 + 10;
int n,m,cur;
int fa[maxn];
vector<pair<int,int> >o;
vector<int>res;
int find(int s){
    return s==fa[s]?s:fa[s]=find(fa[s]);
}
inline void merge(int s,int t){
    int fa_s=find(s);
    int fa_t=find(t);
    if(fa_s!=fa_t){
        --cur;
        fa[fa_s]=fa_t;
    }
}
int main() {
#ifndef ONLINE_JUDGE
    freopen("1.txt","r",stdin);
#endif
    while(scanf("%d%d",&n,&m)!=EOF) {
        o.clear();
        res.clear();
        for (register int i = 0; i < n; ++i)fa[i] = i;
        for (register int i = 1, u, v; i <= m; ++i) {
            scanf("%d%d", &u, &v);
            o.emplace_back(make_pair(u, v));
        }
        cur = n;
        res.emplace_back(n);
        for (register int i = o.size() - 1; i > 0; --i) {
            merge(o[i].first, o[i].second);
            res.emplace_back(cur);
        }
        for (register int i = res.size() - 1; i >= 0; --i) {
            printf("%d\n", res[i]);
        }
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/czy-power/p/11433052.html