HDU4496 D-City【基础并查集】

Problem Description

Luxer is a really bad guy. He destroys everything he met. 
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input. 
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.

Input

First line of the input contains two integers N and M. 
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line. 
Constraints: 
0 < N <= 10000 
0 < M <= 100000 
0 <= u, v < N. 

Output

Output M lines, the ith line is the answer after deleting the first i edges in the input.

Sample Input

5 10 0 1 1 2 1 3 1 4 0 2 2 3 0 4 0 3 3 4 2 4

Sample Output

1 1 1 2 2 2 2 3 4 5

Hint

The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there's only 1 connected block at first. The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together. But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block. Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.

题意:这个小家伙每次删除一条边(初始时每对节点间都有边相连),问每次删除一条边后有几个联通块。

思路:比较基础的并查集应用,不明白的可以看这篇博客并查集 ,并查集是相连在一起,这题需要反着来,不断加边,用数组记录下联通块的数量,最后输出即可。

#include<cstdio>
#include<cstring>
#include <iostream>
#include<algorithm>
using namespace std;
const int N=10005;
const int M=100005;
int pre[N],r[N],s[M];
int n,m;
struct node
{
    int x,y;
}a[M];
void init(int n)
{
    for(int i = 0;i < n;++i)
    {
        pre[i]=i;
        r[i]=0;
    }
}

int findpre(int x)
{
    if(pre[x] == x)
        return x;
    return pre[x] = findpre(pre[x]);
}

void join(int x,int y)
{
    x = findpre(x);
    y = findpre(y);
    if(x == y)
        return;
    if(r[x] < r[y])
        pre[x] = y;
    else
    {
        pre[y] = x;
        if(r[x] == r[y])
            r[x]++;
    }
}

bool same(int x,int y)
{
    return findpre(x) == findpre(y);
}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        for(int i = 0; i < m; ++i)
            scanf("%d%d",&a[i].x,&a[i].y);
        init(n);
        int ans = n;
        for(int i = m-1; i >= 0; --i)
        {
            s[i] = ans;
            if(!same(a[i].x,a[i].y))
                --ans;
            join(a[i].x,a[i].y);
        }
        for(int i = 0; i < m; ++i)
            printf("%d\n",s[i]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41785863/article/details/83832462