hdu-1258 Sum It Up(dfs+去重)

Problem Description
Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.
 

Input
The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.
 

Output
For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.
 

Sample Input
 
  
4 6 4 3 2 2 1 15 
3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 250 0
 

Sample Output
 
  
Sums of 4:
43+12+22+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25
 

Source

题意很简单,直接dfs,但输出的时候需要去重。。。一开始想的是记录找到的上一组数据,然后比较,相同的话不输出。结果WR,研究了大神的代码,发现只是相同的数不必再搜。。。然后达到了去重的效果。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n,m;
int a[25];
int s[100];
int f;
void dfs(int x,int t,int k)//t和  k找到的个数
{
    if(t>n)return ;
    if(t==n)
    {
        f=1;
        printf("%d",s[0]);
        for(int i=1; i<k; i++)
            printf("+%d",s[i]);
        printf("\n");
    }
    for(int i=x-1; i>=0; i--)
    {
        if(a[i]<=n)
        {
            s[k]=a[i];
            dfs(i,t+a[i],k+1);
            while(i-1>=0&&a[i]==a[i-1])i--;//重点在这里!!!
        }
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m),n||m)
    {
        f=0;
        for(int i=0; i<m; i++)
        {
            scanf("%d",&a[i]);
        }
        sort(a,a+m);
        memset(s,0,sizeof(s));;
        printf("Sums of %d:\n",n);
        dfs(m,0,0);
        if(f==0)
            printf("NONE\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/zitian246/article/details/79502107
今日推荐