数据型dfs(去重)HDU1258

Sum It Up

Description

Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is 4,3,2,2,1,14,3,2,2,1,1, then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.

Input 
The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,…,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,…,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.

Output 
For each test case, first output a line containing ‘Sums of’, the total, and a colon. Then output each sum, one per line; if there are no sums, output the line ‘NONE’. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.

Sample Input 
4 6 4 3 2 2 1 1 
5 3 2 1 1 
400 12 50 50 50 50 50 50 25 25 25 25 25 25 
0 0

Sample Output 
Sums of 4: 

3+1 
2+2 
2+1+1 
Sums of 5: 
NONE 
Sums of 400: 
50+50+50+50+50+50+25+25+25+25 
50+50+50+50+50+25+25+25+25+25+25
 

题意:把用n个数里几个数加起来等于t的所有情况列举出来

一开始我就直接搜了(毕竟我比较菜

错误代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<cstring>
int n,t;
int a[15];
int visit[15];
bool j;
using namespace std;

int judge(int x)
{
	if(x>n||visit[x]==1) return 0;
	else return 1;
}

void dfs(int deep, int num)
{
	if(deep>n||num>t) return;
	if(num==t)
	{
		j=true;
		int z=0;
		for(int i=1; i<=n; i++)
		{
			if(visit[i]==1)
			{
				z++;
				if(z==1) printf("%d",a[i]);
				else printf("+%d", a[i]);
			}
		}
		printf("\n");
	}
	for(int i=1; i<=n; i++)
	{
		if(judge(i))
		{
			visit[i]=1;
			dfs(deep+1, num+a[i]);
			visit[i]=0;
			if(i<n&&a[i]==a[i+1]) i++;
		}
	}
	
}

int main()
{
	while(cin>>t>>n&&n&&t)
	{
		j=false;
		a[0]=0;
		printf("Sums of %d:\n", t);
		for(int i=1; i<=n; i++)
		{
			cin>>a[i];
		}
		dfs(0,a[0]);
		if(!j) printf("NONE\n");
	}
	return 0;
} 

结果明显不对:

看了一下大佬的代码以后发现要去重

然后改了一下

AC代码:

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<cstring>
int n,t,cnt;
int a[15],b[15];
int visit[15];
bool j;
using namespace std;

int judge(int x)
{
	if(x>n||visit[x]==1) return 0;
	else return 1;
}

void dfs(int deep, int num)
{
	if(deep>n||num>t) return;
	if(num==t)
	{
		j=true;
		int z=0;
		for(int i=1; i<=cnt; i++)
		{
			z++;
			if(z==1) printf("%d",b[i]);
			else printf("+%d", b[i]);
		}
		printf("\n");
	}
	for(int i=1; i<=n; i++)
	{
		if(judge(i))
		{
			if(cnt>0&&b[cnt]<a[i])   //确保格式从大到小
			{
				continue;
			}
			b[++cnt]=a[i];			//记录这次搜到底的结果 
			visit[i]=1;
			dfs(deep+1, num+a[i]);
			visit[i]=0;
			cnt--;
			while(i<n&&a[i]==a[i+1]) i++;    //去重 
		}
	}
	
}

int main()
{
	while(cin>>t>>n&&n&&t)
	{
		j=false;
		cnt=0;
		printf("Sums of %d:\n", t);
		for(int i=1; i<=n; i++)
		{
			cin>>a[i];
		}
		dfs(1,0);
		if(!j) printf("NONE\n");
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/qq_42762354/article/details/88979635