hdu 1258 Sum It Up

Sum It Up

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)

Total Submission(s) : 13   Accepted Submission(s) : 5

Problem Description

Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.

Input

The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.

Output

For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.

Sample Input

 

4 6 4 3 2 2 1 1 5 3 2 1 1 400 12 50 50 50 50 50 50 25 25 25 25 25 25 0 0

Sample Output

 

Sums of 4: 4 3+1 2+2 2+1+1 Sums of 5: NONE Sums of 400: 50+50+50+50+50+50+25+25+25+25 50+50+50+50+50+25+25+25+25+25+25

#include<stdio.h>
#include<string.h>
#include <algorithm>
using namespace std;
int b[1000],a[1000],sum=0,M,n,p=0;
int cmp(int a,int b)//定义比较函数,使其从大到小排;
{
    return a>b;
}
void print_(int l)//输出函数
{
    for(int i=0;i<=l;i++)
    {
        if(i!=l)
        printf("%d+",b[i]);
        else
        printf("%d\n",b[i]);
    }
}
void dfs(int x,int l,int sum)//用x来代表起始位置,l代表已存入数组长度,sum用来传递目前的和;
{
    int t=0;
    for(int i=x;i<n;i++)
    {
         b[l]=a[i];
         t=sum+a[i];
        if(t==M)//如果t=m则执行输出函数并且,并且进行方案数的加1;
        {
           p++;
           print_(l);
        }
        dfs(i+1,l+1,sum+a[i]);//进入下一层深搜
        while(i+1<n&&a[i]==a[i+1])//这里用来去重,如果下一次要搜索的数和上一次一样则跳过下次搜索
        i++;
    }
}
int main()
{
    while(scanf("%d %d",&M,&n),M!=0&&n!=0)
    {
        p=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        sort(a,a+n,cmp);
        printf("Sums of %d:\n",M);
        dfs(0,0,0);
        if(p==0)printf("NONE\n");
    }
}

猜你喜欢

转载自blog.csdn.net/qq_41661918/article/details/84636911