Sum It Up (搜索加去重)

Sum It Up

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)

Total Submission(s) : 12   Accepted Submission(s) : 6

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.

Input

The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.

Output

For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.

Sample Input

4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0

Sample Output

Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25

这道题的关键就是去重了因为有重复数字嘛,比如:400 12 50 50 50 50 50 50 25 25 25 25 25 25这个例子有重复数字,如果全排列的话会重复,所以去重就好了,最简单的一种就是开一个数组,然后重复的不忘进去放,但是既然是递归的话我们就可以利用递归的特性,我设一个标记位,把上一位的标记如果我当前这个大于这个标记位才可以往进去放。所以就完美解决了这个不重复全排列,很水的一道题。

# include <iostream>
# include <cstring>

using namespace std;

const int maxn = 50;
int a[maxn];
int b[maxn];
int sum, t;
bool flag;

void dfs(int vis, int f, int s) //vis是下标,f是当前b数组的下标,s是和
{
   if(s > sum) return ;
   if(s == sum)
   {
       flag = true;
     for(int i = 0; i < f; i++)
       {
           i != f - 1? cout << b[i]<< "+" : cout << b[i] << endl;
       }
   }
   int k = -1;
   for(int i = vis; i < t; i++)
   {
       if(k != a[i])
       {
           b[f] = a[i];
           k = a[i];
           dfs(i + 1, f + 1, s + b[f]);
       }
   }
}

int main(int argc, char *argv[])
{
    while(cin >> sum >> t, t || sum)
    {
        for(int i = 0; i < t; i++)
        {
            cin >> a[i];
        }
        cout << "Sums of "<< sum <<":" << endl;
        flag = false;
        dfs(0, 0, 0);
        if(!flag)
        {
            cout << "NONE" << endl;
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/I_O_fly/article/details/82958560