Sum It Up

Sum It Up

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7904    Accepted Submission(s): 4151


 

Problem Description

Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.

 

Input

The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.

 

Output

For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.

 

Sample Input

 

4 6 4 3 2 2 1 1 5 3 2 1 1 400 12 50 50 50 50 50 50 25 25 25 25 25 25 0 0

 

Sample Output

 

Sums of 4: 4 3+1 2+2 2+1+1 Sums of 5: NONE Sums of 400: 50+50+50+50+50+50+25+25+25+25 50+50+50+50+50+25+25+25+25+25+25

 

Source

#include<iostream>  //怎么解决重复的问题 
#include<stdio.h>
#include<algorithm>
#include<cstring>
using namespace std;
int n,m,k,f=0,a[1001];
bool vis[1001];
int cmp(int x,int y)
{
    return x>y;
}
void DFS(int sum,int t)
{
    if(sum==n)
    {
        f=1;
        bool s=false;
        for(int i=1; i<=m; i++)
            if(vis[i])                         如果我加了,我就输出
            {
                
                if(!s)
                {
                    cout<<a[i];
                    s=true;
                }
                else
                {
                    cout<<"+"<<a[i];
                }
            }
        cout<<endl;
        return ;
    }
    for(int i=t; i<=m; i++)   //正序输出后,防倒序输出, 
    {
        vis[i]=true;
        DFS(sum+a[i],i+1);
        vis[i]=false;
        while(a[i]==a[i+1])   //防止重复  ,这点很棒 
            i++;

    }
}
int main()
{
    while(~scanf("%d%d",&n,&m),n||m)
    {
        a[0]=0;
        memset(vis,false,sizeof(vis));
        for(int i=1; i<=m; i++)
        {
            scanf("%d",&a[i]);
            a[0]+=a[i];
        }
        
        printf("Sums of %d:\n",n);
        if(a[0]<n)
        {
            printf("NONE\n");
            continue;
        }
        DFS(0,0);
        if(f==0)
        cout<<"NONE\n";
        f=0;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41325698/article/details/81950845
sum
今日推荐