HDU 2058 The Sum Problem

http://acm.hdu.edu.cn/showproblem.php?pid=2058

Problem Description
Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.
 
Input
Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.
 
Output
For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.
 
Sample Input
20 10
50 30
0 0
 
Sample Output
[1,4]
[10,10]
 
[4,8]
[6,9]
[9,11]
[30,30]
 
代码:
#include <bits/stdc++.h>
using namespace std;

int n,m;

int main() {
    while(~scanf("%d%d", &n, &m)) {
            if( n == 0 && m == 0) break;
       for(int i = sqrt(2 * m); i >= 1; i --) {
            int a = (m - ((i - 1) * i) / 2) / i;
            if(m == a * i + (i * (i - 1)) / 2)
            cout<< '[' << a << ',' << a + i - 1 << ']' <<endl;
        }
        printf("\n");
    }
    return 0;
}

  

猜你喜欢

转载自www.cnblogs.com/zlrrrr/p/9380144.html