Find The Multiple

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111

题意:寻找一个数,能除开所给的n,且这个数是由1或0组成的。则从1开始判断,每次是*10+1或*10则判断。

考虑到用DFS,但是n<=200,则完全可以用long long 存下(这是做题的关键所在)。


#include<stdio.h>
#include<iostream>
using namespace std;
long long n;
int s;
int f;
void DFS(long long k,long long x)
{
    if(f)
        return;
    if(x>=s)
        return;
    if(k%n==0)
    {
        f=1;
        cout<<k<<endl;
        return;
    }
    DFS(k*10,x+1);
    DFS(k*10+1,x+1);
}
int main()
{
    while(cin>>n)
    {
        if(n==0)
            break;
        f=0;
        for(s=1;; s++)
        {
            if(f)
                break;
            DFS(1,0);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40721948/article/details/80368611
今日推荐