A - Find The Multiple POJ - 1426

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111
本道题就是一道简单的搜索题,看到题的时候一直以为m的长度可以达到100位,就一直在想怎么用数组做,可结果总是出错,其实m的取值范围在longlongint范围之内,直接进行搜索,如果搜索的那个数能被n除尽,就结束。
#include<stdio.h>
#include<string.h>
int n,flag;
void dfs(long long int x,int s)
{
    if(s>=19)return;
    if(flag)return;
    if(x%n==0)
    {
        flag=1;
        printf("%lld\n",x);
        return;
    }
    dfs(x*10,s+1);
    dfs(x*10+1,s+1);
}
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        flag=0;
        dfs(1,0);
    }
}

猜你喜欢

转载自blog.csdn.net/guoshuyan12/article/details/75453602
今日推荐