C - Find The Multiple

C - Find The Multiple

 
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111




#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
int n,flag;
void dfs(unsigned long long x,int step)
{
    if(flag==1)
        return ;
    if(step==19)
        return ;
    if(x%n==0)
    {
        cout<<x<<endl;
        flag=1;
        return ;
    }
    else
        dfs(x*10+0,step+1);
        dfs(x*10+1,step+1);
}
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        flag=0;
        dfs(1,0);
    }
    return 0;
}




猜你喜欢

转载自blog.csdn.net/lihuanz/article/details/80671301
今日推荐