PTA 4-2 奇数值结点链表 (50分)

本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中奇数值的结点重新组成一个新的链表。链表结点定义如下:
struct ListNode {
    int data;
    ListNode *next;
};

函数接口定义:

struct ListNode *readlist();
struct ListNode *getodd( struct ListNode **L );

函数readlist从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到-1−1时表示输入结束,函数应返回指向单链表头结点的指针。

函数getodd将单链表L中奇数值的结点分离出来,重新组成一个新的链表。返回指向新链表头结点的指针,同时将L中存储的地址改为删除了奇数值结点后的链表的头结点地址(所以要传入L的指针)。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

struct ListNode {
    int data;
    struct ListNode *next;
};

struct ListNode *readlist();
struct ListNode *getodd( struct ListNode **L );
void printlist( struct ListNode *L )
{
     struct ListNode *p = L;
     while (p) {
           printf("%d ", p->data);
           p = p->next;
     }
     printf("\n");
}

int main()
{
    struct ListNode *L, *Odd;
    L = readlist();
    Odd = getodd(&L);
    printlist(Odd);
    printlist(L);

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:1 2 2 3 4 5 6 7 -1
输出样例:

1 3 5 7 
2 2 4 6

程序代码:*

struct ListNode *readlist()
{
    ListNode *p1,*p2,*head;//声明结构体类型的指针
    int n=0;//声明变量,用来记录是否是第一个节点
    int number;//声明变量,用来判断是否结束
    p1=p2=(ListNode*)malloc(sizeof(struct ListNode));//开辟空间
    scanf("%d",&number); //输入
    head=NULL;//将头赋值为空
    while(number!=-1)//进入循环,当number等于-1时跳出循环
    {
        p1->data=number;//如果number不等于-1,将其赋值给节点数据域
        n=n+1;//节点数加1
        if(n==1)//判断是否是头节点
            head=p1;//记录头
        else
            p2->next=p1;//连接链表
        p2=p1;//驱动
        p1=(ListNode*)malloc(sizeof(struct ListNode));//继续开辟空间
        scanf("%d",&number); //输入number
    }
    p2->next=NULL; //给尾节点赋值为空
    return head;//返回头节点
}
struct ListNode *getodd( struct ListNode **L )
{ 
    ListNode *p,*r,*s,*head1,*head2;
    p=*L;
    head1=(ListNode*)malloc(sizeof(struct ListNode));
    head2=(ListNode*)malloc(sizeof(struct ListNode));
    head1->next=NULL;
    head2->next=NULL;
    r=head1;
    s=head2;
    while(p)
    {
        if(p->data%2!=0)
        {
            r->next=p;
            r=p;
        }
        else
        {
            s->next=p;
            s=p;
        }
        p=p->next;
    }
    r->next=NULL;
    s->next=NULL;
    *L=head2->next;
    return head1->next;
}

说明:同样能够达到题目要求的效果,但是编译通不过!还在找原因,知道为什么的朋友交流一下。

猜你喜欢

转载自blog.csdn.net/qq_35550443/article/details/53418057