PTA 习题11-7 奇数值结点链表 (20 分)

PTA 习题11-7 奇数值结点链表 (20 分)
本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中奇数值的结点重新组成一个新的链表。链表结点定义如下:

struct ListNode {
    
    
    int data;
    ListNode *next;
};

函数接口定义:

struct ListNode *readlist();struct ListNode *getodd( struct ListNode **L );

函数readlist从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1时表示输入结束,函数应返回指向单链表头结点的指针。
函数getodd将单链表L中奇数值的结点分离出来,重新组成一个新的链表。返回指向新链表头结点的指针,同时将L中存储的地址改为删除了奇数值结点后的链表的头结点地址(所以要传入L的指针)。

裁判测试程序样例:

#include <stdio.h>#include <stdlib.h>
struct ListNode {
    
    
    int data;
    struct ListNode *next;
};
struct ListNode *readlist();struct ListNode *getodd( struct ListNode **L );void printlist( struct ListNode *L ){
    
    
     struct ListNode *p = L;
     while (p) {
    
    
           printf("%d ", p->data);
           p = p->next;
     }
     printf("\n");
}
int main(){
    
    
    struct ListNode *L, *Odd;
    L = readlist();
    Odd = getodd(&L);
    printlist(Odd);
    printlist(L);

    return 0;
}
/* 你的代码将被嵌在这里 */

输入样例:

1 2 2 3 4 5 6 7 -1

输出样例:

1 3 5 7 
2 2 4 6 
struct ListNode *readlist()
{
    
    
    struct ListNode *head=NULL,*tail=head,*p;
    int n=1;
    while(n!=-1){
    
    
        scanf("%d",&n);
        if(n!=-1){
    
    
            p=(struct ListNode*)malloc(sizeof(struct ListNode));
            p->data=n;
            if(head==NULL) head=p;//双等于
            else tail->next=p;//tailnext
            tail=p;
        }
    }
    return head;//记得return
}

struct ListNode *getodd( struct ListNode **L )
{
    
    
    struct ListNode *h1=NULL,*h2=NULL,*tail1=h1,*tail2=h2,*p;
    int a;
    while(*L){
    
    //用while
        a=(*L)->data;//括号
        p=(struct ListNode*)malloc(sizeof(struct ListNode));
        p->next=NULL;
        p->data=a;//把if和else里的这一句提出来
        if(a%2){
    
    
            //p->data=a;
            if(h1==NULL) h1=p;
            else tail1->next=p;
            tail1=p;
        }
        else
        {
    
    
           // p->data=a;
            if(h2==NULL) h2=p;
            else tail2->next=p;
            tail2=p;
        }
        (*L)=(*L)->next;
    }
    *L=h2;
    return h1;
}

猜你喜欢

转载自blog.csdn.net/qq_53749266/article/details/114897191