PTA 实验11-2-2 学生成绩链表处理 (20 分)

PTA 实验11-2-2 学生成绩链表处理 (20 分)
本题要求实现两个函数,一个将输入的学生成绩组织成单向链表;另一个将成绩低于某分数线的学生结点从链表中删除。

函数接口定义:

struct stud_node *createlist();
struct stud_node *deletelist( struct stud_node *head, int min_score );

函数createlist利用scanf从输入中获取学生的信息,将其组织成单向链表,并返回链表头指针。链表节点结构定义如下:

struct stud_node {
    
    
    int              num;      /*学号*/
    char             name[20]; /*姓名*/
    int              score;    /*成绩*/
    struct stud_node *next;    /*指向下个结点的指针*/
};

输入为若干个学生的信息(学号、姓名、成绩),当输入学号为0时结束。
函数deletelist从以head为头指针的链表中删除成绩低于min_score的学生,并返回结果链表的头指针。

裁判测试程序样例:

#include <stdio.h>#include <stdlib.h>
struct stud_node {
    
    
     int    num;
     char   name[20];
     int    score;
     struct stud_node *next;
};
struct stud_node *createlist();struct stud_node *deletelist( struct stud_node *head, int min_score );
int main(){
    
    
    int min_score;
    struct stud_node *p, *head = NULL;

    head = createlist();
    scanf("%d", &min_score);
    head = deletelist(head, min_score);
    for ( p = head; p != NULL; p = p->next )
        printf("%d %s %d\n", p->num, p->name, p->score);

    return 0;
}
/* 你的代码将被嵌在这里 */

输入样例:

1 zhang 78
2 wang 80
3 li 75
4 zhao 85
0
80

输出样例:

2 wang 80
4 zhao 85
struct stud_node* createlist() {
    
    
    int number;
    scanf("%d", &number);
    struct stud_node* p,*head, * tail = head = NULL;
    while (number != 0) {
    
    
        p = (struct stud_node*)malloc(sizeof(struct stud_node));
        p->num = number;
        if (head == NULL) head = p;
        else tail->next = p;
        tail=p;
        tail->next = NULL;
        scanf("%s %d", &p->name, &p->score);
        scanf("%d", &number);
    }
    return head;
}//详见https://blog.csdn.net/qq_53749266/article/details/115046995
/*定义在外界才是全局变量!!
struct stud_node {
     int    num;
     char   name[20];
     int    score;
     struct stud_node *next;
};
struct stud_node *head, *tail;
*/
struct stud_node *deletelist(struct stud_node *head,int min_score)
{
    
    
    struct stud_node *p,*tail;
    //if(head==NULL) return NULL;放到下面去防止删空了!!
    while(head!=NULL&&head->score<min_score) {
    
    //如果前面没有了head==NULL,这里要加上写head还要!=NULL才行!!!
        p=head;
        head=head->next;
        free(p);
    }
    if(head==NULL) return NULL;
    p=head;
    tail=p->next;
    while(tail){
    
    
        if(tail->score<min_score){
    
    
            p->next=tail->next;//连接前一节与之后一节,用p就够了,head永远在那里。
            free(tail);
        }else p=tail;//p前进,永远让p小于tail一节。
        tail=tail->next;
    }
    return head;
}

猜你喜欢

转载自blog.csdn.net/qq_53749266/article/details/115047044