单链表结点删除--PTA

本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中所有存储了某给定值的结点删除。链表结点定义如下:

struct ListNode {
    int data;
    ListNode *next;
};

函数接口定义:

struct ListNode *readlist();
struct ListNode *deletem( struct ListNode *L, int m );

函数readlist从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1时表示输入结束,函数应返回指向单链表头结点的指针。
函数deletem将单链表L中所有存储了m的结点删除。返回指向结果链表头结点的指针。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

struct ListNode {
    int data;
    struct ListNode *next;
};

struct ListNode *readlist();
struct ListNode *deletem( struct ListNode *L, int m );
void printlist( struct ListNode *L )
{
     struct ListNode *p = L;
     while (p) {
           printf("%d ", p->data);
           p = p->next;
     }
     printf("\n");
}

int main()
{
    int m;
    struct ListNode *L = readlist();
    scanf("%d", &m);
    L = deletem(L, m);
    printlist(L);

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

10 11 10 12 10 -1
10

输出样例:

11 12 

代码:


struct ListNode *readlist()
{
	struct ListNode *p=NULL,*head=NULL,*tail=NULL;
	int data;
	head=(struct ListNode*)malloc(sizeof(struct ListNode));
	head->next=NULL;
	tail=head;
	scanf("%d",&data);
	while(1)
	{
        if(data==-1)break;
		p=(struct ListNode*)malloc(sizeof(struct ListNode));
		
		p->data=data;
		p->next=NULL;
//?????????????????????????????????????
        //tail=p;                    ??
		tail->next=p; //注意:这两句  ??
		tail=p;       //不能交换顺序  ??
//?????????????????????????????????????
        scanf("%d",&data);
	}
	return head;
}
struct ListNode *deletem( struct ListNode *L, int m )
{
	struct ListNode *p=L;
	int flag;
	while(p->next!=NULL)
	{
		flag=0;
		if(p->next->data<=m)
		{
			p->next=p->next->next;
			flag=1;
		}
		if(flag==0)p=p->next;
	}
	return L->next;
}

在这里插入图片描述

猜你喜欢

转载自blog.csdn.net/qq_44256227/article/details/89743052