寒假私训——二分 D - Distributing Ballot Boxes

Distributing Ballot Boxes

题目描述

 Today, besides SWERC'11, another important event is taking place in Spain which rivals it in importance: General Elections. Every single resident of the country aged 18 or over is asked to vote in order to choose representatives for the Congress of Deputies and the Senate. You do not need to worry that all judges will suddenly run away from their supervising duties, as voting is not compulsory.
The administration has a number of ballot boxes, those used in past elections. Unfortunately, the person in charge of the distribution of boxes among cities was dismissed a few months ago due to nancial restraints. As a consequence, the assignment of boxes to cities and the lists of people that must vote in each of them is arguably not the best. Your task is to show how efficiently this task could have been done.
The only rule in the assignment of ballot boxes to cities is that every city must be assigned at least one box. Each person must vote in the box to which he/she has been previously assigned. Your goal is to obtain a distribution which minimizes the maximum number of people assigned to vote in one box.
In the first case of the sample input, two boxes go to the fi rst city and the rest to the second, and exactly 100,000 people are assigned to vote in each of the (huge!) boxes in the most efficient distribution. In the second case, 1,2,2 and 1 ballot boxes are assigned to the cities and 1,700 people from the third city will be called to vote in each of the two boxes of their village, making these boxes the most crowded of all in the optimal assignment. 

Input
The fi rst line of each test case contains the integers N (1<=N<=500,000), the number of cities, and B(N<=B<=2,000,000), the number of ballot boxes. Each of the following N lines contains an integer a i,(1<=a i<=5,000,000), indicating the population of the i th city.
A single blank line will be included after each case. The last line of the input will contain -1 -1 and should not be processed.
Output
For each case, your program should output a single integer, the maximum number of people assigned to one box in the most efficient assignment.
Sample Input

2 7
200000
500000

4 6
120
2680
3400
200

-1 -1

Sample Output

100000
1700

题目大意

该题让你求n个城市,总共有b个信箱,下面n行是每个城市信封的个数。让你均衡地分配这些信箱,使得信箱装信数最小。

解题思路

二分算法,先找到l和r(目标值的范围),很显然,最小值l=1,r=max(a[i])。
再找chack函数:算出当前mid下,总共的信箱数sum,如果sum>b,说明mid太小,要取右部。
反思:此题思路比较简单,但有一个坑点,就是chack中求sum时,只要有信,sum就要加一。

代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
int a[500100],n,b;
bool chack(int x)
{
    int sum=0;
    for(int i=1;i<=n;i++)
    {
        sum+=a[i]/x;
        if(a[i]%x!=0) sum++;//注意只要有人,信箱就一定要有
    }
    if(sum>b) return 1;
    return 0;
}
int main()
{
    while(~scanf("%d%d",&n,&b))
    {
        if(n==-1&&b==-1) break;
        int mi=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            if(a[i]>mi) mi=a[i];
        }
        int L=1,R=mi;
        while(L<R)
        {
            int mid=(L+R)/2;
            if(chack(mid))L=mid+1;
            else R=mid;
        }
        printf("%d\n",R);
    }
    return 0;
}
发布了36 篇原创文章 · 获赞 1 · 访问量 1393

猜你喜欢

转载自blog.csdn.net/atnanajiang/article/details/104061952
今日推荐