Distributing Ballot Boxes

题目:

Today, besides SWERC'11, another important event is taking place in Spain which rivals it in importance: General Elections. Every single resident of the country aged 18 or over is asked to vote in order to choose representatives for the Congress of Deputies and the Senate. You do not need to worry that all judges will suddenly run away from their supervising duties, as voting is not compulsory. 
The administration has a number of ballot boxes, those used in past elections. Unfortunately, the person in charge of the distribution of boxes among cities was dismissed a few months ago due to nancial restraints. As a consequence, the assignment of boxes to cities and the lists of people that must vote in each of them is arguably not the best. Your task is to show how efficiently this task could have been done. 
The only rule in the assignment of ballot boxes to cities is that every city must be assigned at least one box. Each person must vote in the box to which he/she has been previously assigned. Your goal is to obtain a distribution which minimizes the maximum number of people assigned to vote in one box. 
In the first case of the sample input, two boxes go to the fi rst city and the rest to the second, and exactly 100,000 people are assigned to vote in each of the (huge!) boxes in the most efficient distribution. In the second case, 1,2,2 and 1 ballot boxes are assigned to the cities and 1,700 people from the third city will be called to vote in each of the two boxes of their village, making these boxes the most crowded of all in the optimal assignment.

Input

The fi rst line of each test case contains the integers N (1<=N<=500,000), the number of cities, and B(N<=B<=2,000,000), the number of ballot boxes. Each of the following N lines contains an integer a i,(1<=a i<=5,000,000), indicating the population of the i th city. 
A single blank line will be included after each case. The last line of the input will contain -1 -1 and should not be processed.

Output

For each case, your program should output a single integer, the maximum number of people assigned to one box in the most efficient assignment.

Sample Input

2 7
200000
500000

4 6
120
2680
3400
200

-1 -1

Sample Output

100000
1700

题意:

给出n个城市,每个城市有ai个人,总共有b个投票箱,每个城市最少有一个投票箱;

问投票箱最多使用人数的最小值;

思路:

二分法;

如果N = M,则容量为城市人口数最多的那个;

如果N < M,我们要把M全部用光,因为用的箱子越多,平均值越小;

所以,我们就可以二分枚举人口数作为投票箱的容量;

如果对于当前容量,我们枚举所有城市需要的箱子数目小于需要的箱子,就说明还可以再小;

如果需要的箱子数大于给出的箱子数,说明最小容量就在当前容量+1到刚才/2的容量数;

代码:

#include<stdio.h>
#include<math.h>
int a[10086111];
int n,m;
int cher(int x)
{
    int cost=0;
    for(int i=0;i<n;i++)
        cost+=ceil(a[i]*1.0/x);
    if(cost>m) return 0;
    else return 1;
}
void fen(int low,int high)
{
    int mid;
    while(low<high)
    {
        mid=(low+high)/2;
        if(cher(mid)==0)
            low=mid+1;
        else high=mid;
    }
    printf("%d\n",high);
}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n==-1&&m==-1)
           break;
        int maxx=-10;
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
            if(a[i]>maxx)
                maxx=a[i];
        }
        fen(1,maxx);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/admin__/article/details/81157814
今日推荐