poj1274(二分图最大匹配的摸板题)

The Perfect Stall
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 27933 Accepted: 12330
Description

Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall.
Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible.
Input

The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.
Output

For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.
Sample Input

5 5
2 2 5
3 2 3 4
2 1 5
3 1 2 5
1 2
Sample Output

4
Source

USACO 40

这里介绍一个非常清楚明白的二分图最大匹配的介绍:
https://blog.csdn.net/c20180630/article/details/70175814
算法分析
算法的核心是找增广路径的过程DFS
对于每个可以与u匹配的顶点v,假如它未被匹配,可以直接用v与u匹配;
如果v已与顶点w匹配,那么只需调用dfs(w)来求证w是否可以与其它顶点匹配,如果dfs(w)返回true的话,仍可以使v与u匹配;如果dfs(w)返回false,则检查u的下一个邻接点…….
在dfs时,要标记访问过的顶点(visit[j]=true),以防死循环和重复计算;每次在主过程中开始一次dfs前,所有的顶点都是未标记的。
主过程只需对每个X部的顶点调用dfs,如果返回一次true,就对最大匹配数加一;一个简单的循环就求出了最大匹配的数目。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
using namespace std;
const int N = 205;
int Cx[N];
int Cy[N];
bool vis[N];
vector<int>ve[N];
int dfs(int x)
{
    for(int i = 0;i < ve[x].size();++i)
    {
        if(!vis[ve[x][i]])
        {
            vis[ve[x][i]] = true;
            if(Cy[ve[x][i]] == -1 || dfs(Cy[ve[x][i]])){
                Cx[x] = ve[x][i];
                Cy[ve[x][i]] = x;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int n,m;
    while(~scanf("%d %d",&n,&m))
    {
        for(int i = 1;i <= n;++i)
        {
            int x;
            scanf("%d",&x);
            for(int j = 0;j < x;++j)
            {
                int y;
                scanf("%d",&y);
                ve[i].push_back(y);
            }
        }
        memset(Cx,-1,sizeof(Cx));
        memset(Cy,-1,sizeof(Cy));
        int ans = 0;
        for(int i = 1;i <= n;++i)
        {
            if(Cx[i] == -1)//找到未匹配的点
            {
                memset(vis,false,sizeof(vis));//每次搜增广路径的时候都要初始化
                ans += dfs(i);//存在增广路径,那么根据增广路径的性质可知,二分图匹配一定加一
            }
        }
        printf("%d\n",ans);
        for(int i = 0;i <= n;++i){
            ve[i].clear();
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36386435/article/details/80087566