POJ - 3020 Antenna Placement (二分图最大匹配)

                                  Antenna Placement

Time Limit: 1000MS   Memory Limit: 65536K

Description

The Global Aerial Research Centre has been allotted the task of building the fifth generation of mobile phone nets in Sweden. The most striking reason why they got the job, is their discovery of a new, highly noise resistant, antenna. It is called 4DAir, and comes in four types. Each type can only transmit and receive signals in a direction aligned with a (slightly skewed) latitudinal and longitudinal grid, because of the interacting electromagnetic field of the earth. The four types correspond to antennas operating in the directions north, west, south, and east, respectively. Below is an example picture of places of interest, depicted by twelve small rings, and nine 4DAir antennas depicted by ellipses covering them. 
 
Obviously, it is desirable to use as few antennas as possible, but still provide coverage for each place of interest. We model the problem as follows: Let A be a rectangular matrix describing the surface of Sweden, where an entry of A either is a point of interest, which must be covered by at least one antenna, or empty space. Antennas can only be positioned at an entry in A. When an antenna is placed at row r and column c, this entry is considered covered, but also one of the neighbouring entries (c+1,r),(c,r+1),(c-1,r), or (c,r-1), is covered depending on the type chosen for this particular antenna. What is the least number of antennas for which there exists a placement in A such that all points of interest are covered? 
 

Input

On the first row of input is a single positive integer n, specifying the number of scenarios that follow. Each scenario begins with a row containing two positive integers h and w, with 1 <= h <= 40 and 0 < w <= 10. Thereafter is a matrix presented, describing the points of interest in Sweden in the form of h lines, each containing w characters from the set ['*','o']. A '*'-character symbolises a point of interest, whereas a 'o'-character represents open space. 
 

Output

For each scenario, output the minimum number of antennas necessary to cover all '*'-entries in the scenario's matrix, on a row of its own.

Sample Input

2
7 9
ooo**oooo
**oo*ooo*
o*oo**o**
ooooooooo
*******oo
o*o*oo*oo
*******oo
10 1
*
*
*
o
*
*
*
*
*
*

Sample Output

17
5

题意: 一个椭圆可以覆盖两个点(只能横着或竖着放椭圆),问至少需要多少个椭圆可以覆盖图中所有的 * .

解题思路: 一个 * 用一个椭圆来覆盖可以保证所有 * 都被覆盖,若两个 * 直线距离为1,则这两个 * 可以用同一个椭圆覆盖,即可以节省一个椭圆,最多节省的椭圆数 = 直线距离为1的两个 * 的匹配数(每个*只能与另外至多一个*匹配),即最少需要椭圆个数 = * 数 - * 最多匹配数。  于是这题就转换成求 * 的最大匹配数,可以将所有的 * 复制到二分图的两个半区,然后直线距离为1的两个*可以匹配,最后总匹配数/2.  即转化成求二分图最大匹配,匈牙利模板即可。

ACCode:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
const int ml = 405;
bool e[ml][ml],vis[ml];
int match[ml],tot;
char mp[ml][ml];
struct Node {
	int x,y;
}node[ml];
bool xyl(int x)
{
	for(int i=1;i<=tot;i++) {
		if(e[x][i] && !vis[i]) {
			vis[i] = true;
			if(match[i] == -1 || xyl(match[i])) {
				match[i] = x;
				return true;
			}
		}
	}
	return false;
}
void createMap()
{
	memset(e,false,sizeof e);
	for(int i=1;i<=tot;i++) {
		for(int j=i+1;j<=tot;j++) {
			if(abs(node[i].x-node[j].x) + abs(node[i].y-node[j].y) == 1)
				e[i][j] = e[j][i] = true;
		}
	}
}
int main()
{
	int T,h,w;
	scanf("%d",&T); 
	while(T--) {
		scanf("%d%d",&h,&w);
		tot = 0;
		for(int i=1;i<=h;i++) {
			for(int j=1;j<=w;j++) {
				cin >> mp[i][j];
				if(mp[i][j] == '*') {
					node[++tot].x = i;
					node[tot].y = j;
				}
			}
		}
		//建图 
		createMap();
		//匈牙利 
		memset(match,-1,sizeof match);
		int cut = 0;
		for(int i=1;i<=tot;i++) {
			memset(vis,false,sizeof vis);
			if(xyl(i)) cut++;
		}
		printf("%d\n",tot-cut/2);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42765557/article/details/98482714